linux下安装或升级GCC 4.8,以支持C++11标准

转载 2016年08月29日 13:52:19

C++11标准在2011年8月份获得一致通过,这是自1998年后C++语言第一次大修订,对C++语言进行了改进和扩充。随后各编译器厂商都各自实现或部分实现了C++中的特性

  如需查看各编译器对C++11的支持程度,请参看文章:


转自:http://www.ddvip.com/tech/1000185987.html

  

本文主要介绍在Linux系统下,如何升级GCC以支持C++11。目前来看GCC是对C++11支持程度最高最多的编译器,但需要GCC4.8及以上版本。


  本文使用操作系统:Centos 6.4 Desktop,64bit;


  原GCC版本:4.4.7;


  目标:升级GCC到4.8.2,以支持C++11。


  获取GCC 4.8.2包:wget http://gcc.skazkaforyou.com/releases/gcc-4.8.2/gcc-4.8.2.tar.gz;


  解压缩:tar -xf gcc-4.8.2.tar.gz;


  进入到目录gcc-4.8.2,运行:./contrib/download_prerequisites。这个神奇的脚本文件会帮我们下载、配置、安装依赖库,可以节约我们大量的时间和精力。


  建立输出目录并到目录里:mkdir gcc-build-4.8.2;cd gcc-build-4.8.2;

  ../configure --enable-checking=release --enable-languages=c,c++ --disable-multilib。--enable-languages表示你要让你的gcc支持那些语言,--disable-multilib不生成编译为其他平台可执行代码的交叉编译器。--disable-checking生成的编译器在编译过程中不做额外检查,也可以使用--enable-checking=xxx来增加一些检查;


  编译:make;注意此步和上一步,比较耗时;


  安装:make install;


  验证:gcc -v;或者g++ -v,如果显示的gcc版本仍是以前的版本,就需要重启系统;或者可以查看gcc的安装位置:which gcc;然后在查看版本 /usr/local/bin/gcc -v,通常gcc都安装在该处位置,如果显示为;


 

  则表示已经升级成功。


  验证是否能够正常工作,以新加入到C++11中的std::array为例。


  vim stdarray.cpp;


  输入C++代码:


  #include


  #include


  #include


  #include


  #include


  int main()


  {


  // construction uses aggregate initialization


  std::array a1{ {1,2,3} }; // double-braces required


  std::array a2 = {1, 2, 3}; // except after =


  std::array a3 = { {std::string("a"), "b"} };


  // container operations are supported


  std::sort(a1.begin(), a1.end());


  std::reverse_copy(a2.begin(), a2.end(),


  std::ostream_iterator(std::cout, " "));


  std::cout << 'n';


  // ranged for loop is supported


  for(auto& s: a3)


  std::cout << s << ' ';


  std::cout << 'n';


  }


  编译:g++ -std=c++11 -o stdarray stdarray.cpp; 一定要加上c++11,否则可能无法编译或者无法运行。


  运行:./stdarray;


  结果输出:

 

  则表示升级后的GCC确实能够支持C++11开发。

CentOS6.8升级gcc到4.8.5总结

From: http://www.cjjjs.com/paper/czxt/2017222114137150.aspx [摘要] 操作系统是CentOS6.8的32位版本,yum自带...
  • JoeBlackzqq
  • JoeBlackzqq
  • 2017年08月14日 14:50
  • 787

在CentOS 6.6 64bit上升级GCC到4.8.2版本

操作系统CentOS6.6 64bit上gcc原版本4.4.7,不能支持C++11的特性~,为了便于YouCompleteMe插件,我希望升级到4.8.2 不能通过yum的方法升级,需要自己手动下载安...
  • tao_627
  • tao_627
  • 2016年01月02日 17:40
  • 4085

Sublime text 3编译环境配置C++11

关于Sublime text3配置编译环境使其支持C++11,在网上找了很多,却发现大部分材料都对Linux和Windows下的环境配置没有做区分,无独有偶在网上找到了一个老外写的有关配置sublim...
  • sqfj2006
  • sqfj2006
  • 2015年05月12日 23:08
  • 2410

centos升级gcc到4.8.1(支持c++11)步骤

centos升级gcc到4.8.1(支持c++11)步骤 下载gcc最新版 wget http://ftp.gnu.org/gnu/gcc/gcc-4.8.1/gcc-4.8.1.tar.gz...
  • abcd1f2
  • abcd1f2
  • 2015年11月10日 15:15
  • 2990

哪个版本的gcc才支持c11

而知,低版本的gcc不支持c11。 (而我此处的eglibc 2.17,和那人的glibc-2.16.0,都是需要支持c11的gcc的) 所以此处想要去搞清楚,什么版本的,哪个版本的,gc...
  • haluoluo211
  • haluoluo211
  • 2017年05月03日 19:25
  • 6484

C/C++学习笔记第一天:MAC OS下搭建GCC和Sublime Text环境

本科的时候学了C C++ 这一路搞研究 也不太需要太多的编程,多半是算法仿真,所以编程感觉越来越差,趁这个暑假赶快拾起来。...
  • chutian_8986
  • chutian_8986
  • 2014年06月27日 18:41
  • 3798

Eclipse ARM IDE 开发环境

一、Eclipse Eclipse的本身只是一个框架平台,但是众多插件的支持,使得Eclipse拥有较好的灵活性。 二、CDT CDT是Eclipse用于扩展Eclipse支持C/C++开发的插...
  • cxw3506
  • cxw3506
  • 2012年12月13日 20:48
  • 13919

linux 查看gcc版本,支持C++11

查看gcc版本 gcc --version命令行编译 g++ -std=c++11 -o main main.cpp
  • guo503604087
  • guo503604087
  • 2016年08月24日 21:05
  • 17307

gcc/g++ 如何支持c11 / c++11标准编译

gcc/g++ 如何支持c11 / c++11标准编译 linux中的编译环境默认可能不支持C++11语法,如R“(abc)”原始字符串。 那么如果一定要编译呢? ...
  • typ2004
  • typ2004
  • 2017年03月01日 23:17
  • 4689
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:linux下安装或升级GCC 4.8,以支持C++11标准
举报原因:
原因补充:

(最多只允许输入30个字)