poj 3250 Bad Hair Day 【单调栈】

Bad Hair Day
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 15953 Accepted: 5388

Description

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ h≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6 

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input

Line 1: The number of cows,  N
Lines 2..N+1: Line  i+1 contains a single integer that is the height of cow  i.

Output

Line 1: A single integer that is the sum of  c 1 through  cN.

Sample Input

6
10
3
7
4
12
2

Sample Output

5


题意:有一排牛都向右看,只有左边的牛比右边的牛高才能看到右边的牛的头顶,问从第一头牛开始到n头牛为止能看到的牛的头顶的总和。


思路: 表示根本就没想到用单调栈,每加入一个新元素,就将栈中的小于等于其的元素弹出。因为如果加入的新元素大于或等于栈中的元素,那么栈中的元素是看不到新元素的头顶的。每次把弹出后栈中的剩余元素的个数相加,在将新元素压入栈中。相加的总和就是总个数。


<pre name="code" class="cpp">#include<stdio.h>
#include<stack>
using namespace std;
int main()
{
	int n,i;
	int a,b;
	long long sum;
	stack<int>s;
	while(~scanf("%d",&n))
	{
		
		scanf("%d",&a);
		s.push(a);
		sum=0;
		for(i=1;i<n;i++)
		{
			scanf("%d",&b);
			while(!s.empty()&&b>=s.top())
			{
				s.pop();
			}
			sum+=s.size();
			s.push(b);
		}
		printf("%lld\n",sum);
	}
	return 0;
} 


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值