题目1019:简单计算器

题目描述:
    读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。
输入:
    测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。
输出:
    对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。
样例输入:
1 + 2
4 + 2 * 5 - 7 / 11
0
样例输出:
3.00

13.36

C++代码:

#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<sstream>
#include<iomanip>
#include<stdio.h>

using namespace std;

vector<string> s;

double getint(string s){
    double a;
    stringstream ss;
    ss<<s;
    ss>>a;
    return a;
}
double countr(double a,double b,string op){
    if(op=="*")
        return a*b;
    if(op=="/")
        return a/b;
    if(op=="+")
        return a+b;
    if(op=="-")
        return a-b;
    return a;
}
double getresult(){
    stack<double> r;
    stack<string> op;
    for(int i=0;i<s.size();i++){
        if(s[i]!="*"&&s[i]!="/"&&s[i]!="+"&&s[i]!="-"){
            if(!op.empty()&&(op.top()=="*"||op.top()=="/")){
                double a=countr(r.top(),getint(s[i]),op.top());
                r.pop();
                op.pop();
                r.push(a);
            }else{
                if(!op.empty()&&op.top()=="-"){
                    op.pop();
                    op.push("+");
                    r.push(-1*getint(s[i]));
                }else{
                    r.push(getint(s[i]));
                }

            }
        }
        else{
            op.push(s[i]);
        }
    }

    while(!op.empty()){
        double a=r.top();
        r.pop();
        double b=r.top();
        r.pop();
        r.push(countr(b,a,op.top()));
        op.pop();
    }
    double result =  r.top();
    return result;
}

int main(){
    string str="";
    while(getline(cin,str)&&str!="0"){
        string m="";
        for(int i=0;i<str.length();i++){
            if(str.at(i)!=' '){
                m+=str.at(i);
            }else{
                s.push_back(m);
                m="";
            }
        }
        s.push_back(m);
        double result = getresult();
        printf("%.2lf\n",result);
       // cout<<setprecision(2)<<std::fixed<<result<<endl;
        s.clear();
        str="";
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值