ZOJ-2965-Accurately Say "CocaCola"!【5th浙江省赛】


ZOJ-2965-Accurately Say “CocaCola”!


                Time Limit: 2 Seconds      Memory Limit: 65536 KB

In a party held by CocaCola company, several students stand in a circle and play a game.

One of them is selected as the first, and should say the number 1. Then they continue to count number from 1 one by one (clockwise). The game is interesting in that, once someone counts a number which is a multiple of 7 (e.g. 7, 14, 28, …) or contains the digit ‘7’ (e.g. 7, 17, 27, …), he shall say “CocaCola” instead of the number itself.

For example, 4 students play this game. At some time, the first one says 25, then the second should say 26. The third should say “CocaCola” because 27 contains the digit ‘7’. The fourth one should say “CocaCola” too, because 28 is a multiple of 7. Then the first one says 29, and the game goes on. When someone makes a mistake, the game ends.

During a game, you may hear a consecutive of p “CocaCola”s. So what is the minimum number that can make this situation happen?

For example p = 2, that means there are a consecutive of 2 “CocaCola”s. This situation happens in 27-28 as stated above. 27 is then the minimum number to make this situation happen.

Input

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 100) which is the number of test cases. And it will be followed by T consecutive test cases.

There is only one line for each case. The line contains only one integer p (1 <= p <= 99).

Output

Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the minimum possible number for the first of the p “CocaCola”s stands for.

Sample Input
2
2
3

Sample Output
27
70

题目链接:ZOJ-2965

题目大意:问第一个有连续p个出现“含有7或者能被7整除的数字”的位置。

题目思路:暴力找规律。需要注意的是270-280,为11个。

以下是代码:

#include <vector>
#include <map>
#include <set>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <string>
#include <cstring>
using namespace std;

int main(){
    int t;
    cin >> t;
    while(t--)
    {
        int p;
        cin >> p;
        if (p == 1) cout << 7 << endl;
        else if (p == 2) cout << 27 << endl;
        else if (p >= 3 && p <= 10) cout << 70 << endl;
        else if (p == 11) cout << 270 << endl;
        else cout << 700 << endl; 
    } 
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值