2017多校训练Contest2: 1011 Regular polygon hdu6055

Problem Description
On a two-dimensional plane, give you n integer points. Your task is to figure out how many different regular polygon these points can make.
 

Input
The input file consists of several test cases. Each case the first line is a numbers N (N <= 500). The next N lines ,each line contain two number Xi and Yi(-100 <= xi,yi <= 100), means the points’ position.(the data assures no two points share the same position.)
 

Output
For each case, output a number means how many different regular polygon these points can make.
 

Sample Input
  
  
4 0 0 0 1 1 0 1 1 6 0 0 0 1 1 0 1 1 2 0 2 1
 

Sample Output
  
  
1 2


数正方形个数

直接枚举两个点后看另外两个点是否存在即可。最后把重复统计的次数除掉

#include<queue>
#include<vector>
#include<cstdio>
#include<string>
#include<cstring>
#include<cassert>
#include<iostream>
#include<algorithm>
using namespace std;
int mp[801][801];
int x[601],y[601];
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		memset(mp,0,sizeof(mp));
		int i,j;
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&x[i],&y[i]);
			x[i]+=400;
			y[i]+=400;
			mp[x[i]][y[i]]=1;
		}
		int ans=0;
		for(i=1;i<=n;i++)
		{
			for(j=i+1;j<=n;j++)
			{
			//	if(i==j)
		//			continue;
				int dx=x[j]-x[i],dy=y[j]-y[i];
			//	if(v[dx][dy]||v[dy][dx])
			//		continue;
			//	v[dx][dy]=true;
			//	v[dy][dx]=true;
				if(mp[x[j]+dy][y[j]-dx]&&mp[x[i]+dy][y[i]-dx])
					ans++;
				if(mp[x[j]-dy][y[j]+dx]&&mp[x[i]-dy][y[i]+dx])
					ans++;
			}
		}
		printf("%d\n",ans/4);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值