杭电 HDU ACM 1698 Just a Hook(线段树 区间更新 延迟标记)

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20889    Accepted Submission(s): 10445


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
      
      
1 10 2 1 5 2 5 9 3
 

Sample Output
      
      
Case 1: The total value of the hook is 24.



#include<iostream>
#include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;
const int INF=100000;
int val[INF+1];
struct node//结构体表示结点
{
    int total;
    int left;
    int right;
    int mark;//是否上次被更新
} tree[INF<<2];

int create(int root,int left ,int right)//建树
{
    tree[root].left=left;
    tree[root].mark=0;
    tree[root].right=right;
    if(left==right)
        return tree[root].total=val[left];
    int a , b,middle=(left+right)>>1;
    a=create(root<<1,left,middle);
    b=create(root<<1|1,middle+1,right);
    return tree[root].total=a+b; //在回溯过程中给total赋值
}

void update_mark(int root)
{
    if(tree[root].mark)
    {//如果被延迟标记过并且此时需要在root的子孙中找需要更新的线段,不管找不找到既然研究到了
   // 此节点就要“落实”此节点total值 ,并使延迟标记下移。
        tree[root].total=tree[root].mark*(tree[root].right-tree[root].left+1);
        if(tree[root].left!=tree[root].right)
            tree[root<<1].mark=tree[root<<1|1].mark=tree[root].mark;
        tree[root].mark=0;
    }
}

int calculate(int root,int left,int right)
{
    update_mark(root);//递归到每个节点都要核实是否具有延迟标记
    if(tree[root].left>right||tree[root].right<left)
        return 0;
    if(left<=tree[root].left&&tree[root].right<=right)
        return tree[root].total;
    int a,b;
    a=calculate(root<<1,left,right);
    b=calculate(root<<1|1,left,right);
    return a+b;
}

int update(int root,int left,int right,int val)
{
    update_mark(root);
    if(tree[root].left>right||tree[root].right<left)
        return tree[root].total;
    if(tree[root].left>=left&&tree[root].right<=right)
    {
        tree[root].mark=val;
        return  tree[root].total=val*(tree[root].right-tree[root].left+1);
    }
    int a,b;
    a=update(root<<1,left,right,val);
    b=update(root<<1|1,left,right,val);
    return tree[root].total=a+b;
}

int main()
{
    int T;
    cin>>T;
    int c=0;
    while(T--)
    {
        int n,q,x,y,z;
        cin>>n;
        for(int i=1; i<=n; i++)
            val[i]=1;
        cin>>q;
        create(1,1,n);
        for(int i=0; i<q; i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            update(1,x,y,z);
        }
        printf("Case %d: The total value of the hook is %d.\n",++c,tree[1].total);
    }
    return  0;
}

 
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值