Poj 3468 A Simple Problem with Integers(线段树 区间更新 延迟标记)

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 73239 Accepted: 22607
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source


目测自己完全可以手写了~ 。题目最下面有提示 回溯加和的时候小心溢出32位整数。

#include<iostream>
#include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;
const int INF=100003;
int val[INF];
struct Tree
{
    int left,right;
    long long total,mark;
} tree[INF<<2];

long long  create(int root ,int left,int right)
{
    tree[root].left=left;
    tree[root].right=right;
    tree[root].mark=0;
    if(left==right)
        return  tree[root].total=val[left];
    long long  a,b,mid=(left+right)>>1;
    a=create(root<<1,left,mid);
    b=create(root<<1|1,mid+1,right);
    return tree[root].total=a+b;
}

void update_mark(int root)
{
    if(tree[root].mark)
    {
        tree[root].total+=tree[root].mark*(tree[root].right-tree[root].left+1);
        if(tree[root].left!=tree[root].right)
        {
            tree[root<<1].mark+=tree[root].mark;
            tree[root<<1|1].mark+=tree[root].mark;
        }
        tree[root].mark=0;
    }
}

long long  calculate(int root ,int left,int right)
{
    update_mark(root);
    if(tree[root].left>right||tree[root].right<left)
        return 0;
    if(tree[root].left>=left&&tree[root].right<=right)
    {
        return tree[root].total;
    }
    long long  a=calculate(root<<1,left,right);
    long long  b=calculate(root<<1|1,left,right);
    return a+b;
}

long long  update(int root , int left,int right,int val)
{
    update_mark(root);
    if(tree[root].left>right||tree[root].right<left)
        return tree[root].total;
    if(tree[root].left>=left&&tree[root].right<=right)
    {
        tree[root].mark+=val;//这里一点需要注意,应重新更新root结点
        update_mark(root);   //让其返回当前结点更新后的最新信息。
        return tree[root].total;
    }
    long long   a=update(root<<1,left,right,val);
    long  long b=update(root<<1|1,left,right,val);
    return tree[root].total=a+b;
}

int main()
{
    int n,q;
    while(cin>>n>>q)
    {
        for(int i=1; i<=n; i++)
            scanf("%d",&val[i]);
        create(1,1,n);
        for(int i=0; i<q; i++)
        {
            getchar();
            char ch;
            int a,b,c;
            scanf("%c",&ch);
            switch(ch)
            {
            case 'Q':
                scanf("%d%d",&a,&b);
                printf("%lld\n",calculate(1,a,b));
                break;
            case 'C':
                scanf("%d%d%d",&a,&b,&c);
                update(1,a,b,c);
                break;
            }
        }
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值