poj2262

Goldbach's Conjecture

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 
Every even number greater than 4 can be 
written as the sum of two odd prime numbers.

For example: 
8 = 3 + 5. Both 3 and 5 are odd prime numbers. 
20 = 3 + 17 = 7 + 13. 
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 
Each test case consists of one even integer n with 6 <= n < 1000000. 
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

Source


著名的哥德巴赫猜想:任何大于4的偶数均可以写成两个奇素数的和。此题需要判断1000000以内的数是否符合哥德巴赫猜想,暴力n穷举法。注意因为要找奇素数,在验证一个奇数是否是素数的时候因子只找奇数就可以了,因为奇数和偶数一定是互素的。在找某个偶数是否可以写成两个奇素数的和的时候,也只找奇数就可以了。
代码如下:
#include<stdio.h>
#include<math.h>

int judge_prime(int x) {
    if (!(x % 2))//如果是偶数直接返回0
        return 0;
    for (int i = 3; i * i <= x; i += 2)//奇数的质因子肯定是奇数
        if (!(x % i))//如果这个奇数有奇数因子,那么就不是素数,返回0
            return 0;
    return 1;
}

int main(void) {
    int x;
    while (scanf("%d", &x), x) {
        int flag = 0;
        for (int i = 3; 2 * i <= x; i += 2) {
            if (judge_prime(i) && judge_prime(x - i)) {//如果i和x-i均是奇素数,就找到了符合哥德巴赫猜想的一组解,输出即可
                printf("%d = %d + %d\n", x, i, x - i);
                flag = 1;//标记找到了一组解
                break;
            }
        }
        if (!flag)
            printf("Goldbach's conjecture is wrong.\n");//如果没有找到解,输出哥德巴赫猜想是错误的
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值