hdoj1723

Distribute Message

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 792    Accepted Submission(s): 347


Problem Description
The contest’s message distribution is a big thing in prepare. Assuming N students stand in a row, from the row-head start transmit message, each person can transmit message to behind M personals, and how many ways could row-tail get the message?
 

Input
Input may contain multiple test cases. Each case contains N and M in one line. (0<=M<N<=30)
When N=0 and M=0, terminates the input and this test case is not to be processed. 
 

Output
Output the ways of the Nth student get message.
 

Sample Input
  
  
4 1 4 2 0 0
 

Sample Output
  
  
1 3
Hint
4 1 : A->B->C->D 4 2 : A->B->C->D, A->C->D, A->B->D
 

Author
威士忌
 

Source
 

Recommend
lcy
#include<stdio.h>
#include<string.h>
int way[31];//way[i]表示第i个人得到消息的方式总数

int main(void) {
    int n, m;
    while (scanf("%d%d", &n, &m), n + m) {
        memset(way,0,sizeof(way));
        way[1]=1;//后面的数值是从way[1]递推出来的
        for (int i = 1; i < n; i++)
            for (int j = 1; j <= m; j++) {
                if (i + j > n)
                    break;
                way[i + j] += way[i];
            }
        printf("%d\n", way[n]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值