1959. 1-Norm Distance

1959. 1-Norm Distance

Description

 For two points with coordinates (坐标) of (x1, y1) and (x2, y2), their 1-norm distance D1 is defined as: D1 = |x1 – x2| + |y1 – y2|. 
Calculate the 1-norm distance of any two given points.

Input

 Two lines, each line has two integers. The first line is x1 and y1; the second line is x2 and y2. All integers in the input are in the range of [-10000000, 10000000].

Output

 The 1-norm distance between the two points.

Sample Input

1 34 1

Sample Output

5

// source code of submission 965945, Zhongshan University Online Judge System
#include <iostream>
using namespace std;

int main()
{
    long int x1,x2,y1,y2,a,b,c;
    cin >> x1 >> y1 >> x2 >> y2;
    a = x1>x2?(x1-x2):(x2-x1);
    b = y1>y2?(y1-y2):(y2-y1);
    c = a + b;
    cout << c << endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值