关闭

安装 163 yum 的过程

标签: yumpythonlinux
878人阅读 评论(0) 收藏 举报
分类:

首先参考这里 来安装 163 yum 源: http://lovesoo.org/rhel-6-0-centos-yum-source-configuration.html

还有

要注意自己的系统是32位还是64位
yum-metadata-parser-1.1.2-3.el5.centos.x86_64  是64位的
yum-metadata-parser-1.1.2-3.el5.centos.i386    是32位的

当安装好这四个软件的了,那就 yum clean all , 这里就报错了:(ps:yum-metadata-parser-1.1.2-3.el5.centos.i386 我是加参数 --nodeps 来安装的


这里提示 python 2.6 不行,要安装 python 2.4 的才可以。。。于是我就安装 python 2.4 了,可是又报错了:



后来我查资料,说2.6的也可以当2.4 的使用的,只需要改点东西,因为之前 make clean all 的时候说没有  sqlitecachec 这个python的库文件,这个文件存在我系统的这里:

ps: .py 是python导入的模块  而.so的文件是给系统用的


于是我把这个目录下面的文件都拷贝到 /usr/lib/python2.6/site-packages

cp /usr/lib/python2.4/site-packages  /usr/lib/python2.6/site-packages


然后 yum clean all 就没问题啦。。。






0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:54319次
    • 积分:923
    • 等级:
    • 排名:千里之外
    • 原创:35篇
    • 转载:18篇
    • 译文:0篇
    • 评论:4条
    最新评论