sicily 1020 Big Integer

1020. Big Integer

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Long long ago, there was a super computer that could deal with VeryLongIntegers(no VeryLongInteger will be negative). Do you know how this computer stores the VeryLongIntegers? This computer has a set of n positive integers: b1,b2,...,bn, which is called a basis for the computer.

The basis satisfies two properties:
1) 1 < bi <= 1000 (1 <= i <= n),
2) gcd(bi,bj) = 1 (1 <= i,j <= n, i ≠ j).

Let M = b1*b2*...*bn

Given an integer x, which is nonegative and less than M, the ordered n-tuples (x mod b1, x mod b2, ..., x mod bn), which is called the representation of x, will be put into the computer.

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains three lines.
The first line contains an integer n(<=100).
The second line contains n integers: b1,b2,...,bn, which is the basis of the computer.
The third line contains a single VeryLongInteger x.

Each VeryLongInteger will be 400 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

Output

For each test case, print exactly one line -- the representation of x.
The output format is:(r1,r2,...,rn)

Sample Input

2

3
2 3 5
10

4
2 3 5 7
13

Sample Output

(0,1,0)
(1,1,3,6)
我的想法是这样的:用一个char数组来存储这400个数字,求余数的话有个技巧,就是逐个逐个求余,比如,123要对10取余,等价于1=1后,再用1*10+2=12来对10取余,得到2,再将2乘以10加上个位数3,得到23,再对10取余,这样得到的3就是取余的结果。
代码如下所示:
// Problem#: 1020
// Submission#: 2936309
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <iostream>
#include <cstdio>
#include <cmath>
#include <string.h>
using namespace std;

int main()
{
    int T, n;
    char x[401];
    int b[100];
    cin >> T;
    for (int count = 0; count < T; count++)
    {
        cin >> n;
        for (int i = 0; i < n; i++)
        {
            cin >> b[i];
        }
        cin >> x;

        cout << "(";

        for (int j = 0; j < n; j++)
        {
            int ans = 0;
            for (int i = 0; i < strlen(x); i++)
            {
                ans = (ans * 10 + (x[i] - '0')) % b[j];
            }
            if (j != n-1)
            {
                cout << ans << ",";
            }
            else
            {
                cout << ans << ")" << endl;
            }
        }
        
    }
}                                 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值