The Book List 2016北京网赛

The Book List
时间限制:1000ms
单点时限:1000ms
内存限制:256MB

描述

The history of Peking University Library is as long as the history of Peking University. It was build in 1898. At the end of year 2015, it had about 11,000 thousand volumes of books, among which 8,000 thousand volumes were paper books and the others were digital ones. Chairman Mao Zedong worked in Peking University Library for a few months as an assistant during 1918 to 1919. He earned 8 Dayang per month there, while the salary of top professors in Peking University is about 280 Dayang per month.

Now Han Meimei just takes the position which Chairman Mao used to be in Peking University Library. Her first job is to rearrange a list of books. Every entry in the list is in the format shown below:

CATEGORY 1/CATEGORY 2/..../CATEGORY n/BOOKNAME

It means that the book BOOKNAME belongs to CATEGORY n, and CATEGORY n belongs to CATEGORY n-1, and CATEGORY n-1 belongs to CATEGORY n-2...... Each book belongs to some categories. Let's call CATEGORY1  "first class category", and CATEGORY 2 "second class category", ...ect. This is an example:

MATH/GRAPH THEORY
ART/HISTORY/JAPANESE HISTORY/JAPANESE ACIENT HISTORY
ART/HISTORY/CHINESE HISTORY/THREE KINDOM/RESEARCHES ON LIUBEI
ART/HISTORY/CHINESE HISTORY/CHINESE MORDEN HISTORY
ART/HISTORY/CHINESE HISTORY/THREE KINDOM/RESEARCHES ON CAOCAO

Han Meimei needs to make a new list on which the relationship between books and the categories is shown by indents. The rules are:

1) The n-th class category has an indent of  4×(n-1) spaces before it.
2) The book directly belongs to the n-th class category has an indent of  4×n spaces before it.
3) The categories and books which directly belong to a category X should be list below X in dictionary order. But all categories go before all books.
4) All first class categories are also list by dictionary order.

For example, the book list above should be changed into the new list shown below:

ART
    HISTORY
        CHINESE HISTORY
            THREE KINDOM
                RESEARCHES ON CAOCAO
                RESEARCHES ON LIUBEI
            CHINESE MORDEN HISTORY
        JAPANESE HISTORY
            JAPANESE ACIENT HISTORY
MATH
    GRAPH THEORY

Please help Han Meimei to write a program to deal with her job.
输入

There are no more than 10 test cases.
Each case is a list of no more than 30 books, ending by a line of "0".
The description of a book contains only uppercase letters, digits, '/' and spaces, and it's no more than 100 characters.
Please note that, a same book may be listed more than once in the original list, but in the new list, each book only can be listed once. If two books have the same name but belong to different categories, they are different books.
输出

For each test case, print "Case n:" first(n starts from 1), then print the new list as required.
样例输入

    B/A
    B/A
    B/B
    0
    A1/B1/B32/B7
    A1/B/B2/B4/C5
    A1/B1/B2/B6/C5
    A1/B1/B2/B5
    A1/B1/B2/B1
    A1/B3/B2
    A3/B1
    A0/A1
    0

样例输出

    Case 1:
    B
        A
        B
    Case 2:
    A0
        A1
    A1
        B
            B2
                B4
                    C5
        B1
            B2
                B6
                    C5
                B1
                B5
            B32
                B7
        B3
            B2
    A3
        B1

multimap直接模拟
注意当目录下 子目录名和书名相同的情况
还有就是 子目录排在书名之前

#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<string>
#include<vector>
#include<deque>
#include<queue>
#include<algorithm>
#include<set>
#include<map>
#include<stack>
#include<time.h>
#include<math.h>
#include<list>
#include<cstring>
#include<fstream>
#include<bitset>
//#include<memory.h>
using namespace std;
#define ll long long
#define ull unsigned long long
#define pii pair<int,int>
#define INF 1000000007

struct S{
    multimap<string,S>mp;
}tS;
multimap<string,S>mp;//当S中的multimap为空时 表示为一本书 否则是目录

void insert(multimap<string,S>&mp,string str){
    string tmp,f,b;//f为'/'前的部分 b为'/'后的部分
    for(string::iterator it=str.begin();it<str.end();++it){
        if(*it=='/'){
            tmp=str;
            f=tmp.assign(str.begin(),it);
            ++it;
            tmp=str;
            b=tmp.assign(it,str.end());
            multimap<string,S>::iterator it1,it2;
            it1=mp.lower_bound(f);//it1 it2保存string为f的范围
            it2=mp.upper_bound(f);
            bool flag=true;//flag=true表示需要创建名为f的子目录
            for(;it1!=it2;++it1){//尝试找有没有名为f的子目录
                if(!(it1->second.mp.empty())){
                    flag=false;
                    break;
                }
            }
            if(flag){
                mp.insert({f,tS});
                it1=mp.find(f);//此时所有key=f的 multimap都为空 随便find一个来添加都可以
            }

            if(!b.empty())
                insert(it1->second.mp,b);

            return;
        }
    }
    //没找到'/' 表示这是一本书
    multimap<string,S>::iterator it1,it2;
    it1=mp.lower_bound(str);//it1 it2保存string为f的范围
    it2=mp.upper_bound(str);
    bool flag=true;//=true表示没有找到同名的书
    for(;it1!=it2;++it1){
        if(it1->second.mp.empty()){//找到同名书了 不需要添加
            flag=false;
            break;
        }
    }
    if(flag)
        mp.insert({str,tS});
}

void print(int numOfSpace,multimap<string,S>&mp){
//先输出目录
    for(multimap<string,S>::iterator it=mp.begin();it!=mp.end();++it){
        if(!(it->second.mp.empty())){
            for(int i=0;i<numOfSpace;++i)
                printf("%4s","");
            cout<<it->first<<endl;
            print(numOfSpace+1,it->second.mp);//递归打印
        }
    }
    //再输出书
    for(multimap<string,S>::iterator it=mp.begin();it!=mp.end();++it){
        if(it->second.mp.empty()){
            for(int i=0;i<numOfSpace;++i)
                printf("%4s","");
            cout<<it->first<<endl;
        }
    }
}

int main()
{
    //freopen("/home/lu/文档/r.txt","r",stdin);
    //freopen("/home/lu/文档/w.txt","w",stdout);
    string str;
    int c=1;
    while(getline(cin,str)){
        if(str=="0"){
            //work
            cout<<"Case "<<c++<<":"<<endl;
            print(0,mp);
            mp.clear();
        }
        else{
            //add
            insert(mp,str);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值