POJ 3069 Saruman's Army 【贪心】

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7513 Accepted: 3837

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of Runits, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

Source

Stanford Local 2006

将这个问题划分成一个个的小问题,每一个从离最左边距离小于等于R的点进行标记,则该小区间内距离小于属于标记点加R的点就可以忽略了。再从下一个不属于标记点+R的点看做最左端,依次进行讨论·······

#include <cstdio>
#include <queue>
#include <stack>
#include <cstring>
#include <iostream>
#include <algorithm>
#define MAX_N   2005
#define MAX(a, b) (a > b)? a: b
#define MIN(a, b) (a < b)? a: b
using namespace std;

int main() {
    int r, n;
    int trp[MAX_N];
    while (scanf("%d%d", &r, &n) != EOF) {
        if (r == -1 && n == -1) break;
        int ans = 0;
        for (int i = 0; i < n; i++) {
            scanf("%d", &trp[i]);
        }
        sort(trp, trp + n);
        int i = 0;
        while (i < n) {
            int temp = trp[i++];
            while (temp + r >= trp[i] && i < n) i++;
            int p = trp[i - 1];
            while (p + r >= trp[i] && i < n) i++;
            temp = trp[i - 1];
            ans++;
        }
        printf("%d\n", ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值