HDU Problem 2647 Reward【拓扑排序】

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7391    Accepted Submission(s): 2317


Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
 

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
 

Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
 

Sample Input
  
  
2 1 1 2 2 2 1 2 2 1
 

Sample Output
  
  
1777 -1
 

Author
dandelion
 

思路:将图倒着存,如果找到一个节点的上一级,就用res数组保存这个节点上级所处的等级,最后做一个统计。

#include <bits/stdc++.h>
#define MAXN 10005
using namespace std;
int n, m, outdegree[MAXN], res[MAXN];
int head[MAXN], num, que[MAXN];
struct node{
    int from, to, next;
}edge[MAXN*2];
void add(int x, int y) {
    edge[num].from = x;
    edge[num].to = y;
    edge[num].next = head[x];
    head[x] = num++;
}
void init() {
    memset(head, -1, sizeof(head));
    memset(outdegree, 0, sizeof(outdegree));
    memset(res, 0, sizeof(res));
    num = 0;
}
void solved() {
    int iq = 0, ans = 0;
    for (int i = 1; i <= n; i++) {
        if (outdegree[i] == 0) {
            que[iq++] = i;
        }
    }
    for (int i = 0; i < iq; i++) {
        for (int k = head[que[i]]; k != -1; k = edge[k].next) {
            outdegree[edge[k].to]--;
            if (outdegree[edge[k].to] == 0) {
                que[iq++] = edge[k].to;
                //记录该节点所在的等级
                res[edge[k].to] = res[edge[k].from] + 1;

            }
        }
    }
    for (int i = 1; i <= n; i++) {
        ans += res[i];
        //如果存在环
        if (outdegree[i] > 0) {
            printf("-1\n"); return ;
        }
    }
    printf("%d\n", ans + 888*n);
}
int main() {
    int a, b;
    while (scanf("%d%d", &n, &m) != EOF) {
        init();
        for (int i = 0; i < m; i++) {
            scanf("%d%d", &a, &b);
            add(b, a); outdegree[a]++;
        }
        solved();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值