See you~ (hdu1892 二维树状数组模板)

See you~

Time Limit : 5000/3000ms (Java/Other)   Memory Limit : 65535/32768K (Java/Other)

Problem Description
Now I am leaving hust acm. In the past two and half years, I learned so many knowledge about Algorithm and Programming, and I met so many good friends. I want to say sorry to Mr, Yin, I must leave now ~~>.<~~. I am very sorry, we could not advanced to the World Finals last year. 
When coming into our training room, a lot of books are in my eyes. And every time the books are moving from one place to another one. Now give you the position of the books at the early of the day. And the moving information of the books the day, your work is to tell me how many books are stayed in some rectangles. 
To make the problem easier, we divide the room into different grids and a book can only stayed in one grid. The length and the width of the room are less than 1000. I can move one book from one position to another position, take away one book from a position or bring in one book and put it on one position. 
 

Input
In the first line of the input file there is an Integer T(1<=T<=10), which means the number of test cases in the input file. Then N test cases are followed. For each test case, in the first line there is an Integer Q(1<Q<=100,000), means the queries of the case. Then followed by Q queries. There are 4 kind of queries, sum, add, delete and move. For example: S x1 y1 x2 y2 means you should tell me the total books of the rectangle used (x1,y1)-(x2,y2) as the diagonal, including the two points. A x1 y1 n1 means I put n1 books on the position (x1,y1) D x1 y1 n1 means I move away n1 books on the position (x1,y1), if less than n1 books at that position, move away all of them. M x1 y1 x2 y2 n1 means you move n1 books from (x1,y1) to (x2,y2), if less than n1 books at that position, move away all of them. Make sure that at first, there is one book on every grid and 0<=x1,y1,x2,y2<=1000,1<=n1<=100.
 

Output
At the beginning of each case, output "Case X:" where X is the index of the test case, then followed by the "S" queries. For each "S" query, just print out the total number of books in that area.
 

Sample Input
  
  
2 3 S 1 1 1 1 A 1 1 2 S 1 1 1 1 3 S 1 1 1 1 A 1 1 2 S 1 1 1 2
 

Sample Output
  
  
Case 1: 1 3 Case 2: 1 4
 

//题意:有一个书架(空间是二维的),初始时每个位置(坐标)上都有1本书,现在有4种操作:“S”:输入x1,y1,x2,y2,求以(x1,y1),(x2,y2)为对角线顶点的矩形区域内共有几本书;“A”:输入x,y,n,往(x,y)这个位置加进去n本书;“D”: 输入x,y,n,在(x,y)这个位置拿掉n本书;“M”:输入x1,y1,x2,y2,n,从(x1,y1)这个位置拿n本书放到(x2,y2)这个位置;

//思路:其实就是一个简单的二维树状数组模板。“S”就是求和,“A”、“D”、“M”其实都可以看成添加操作(减的话就是加个负的)。主要要注意的就是些细节,见代码。


//二维树状数组模板题

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
using namespace std;

#define size 1010

int n;
//这里的+1很有必要,不然会出现各种奇怪的错误...
int c[size + 1][size + 1];

int lowbit(int x)
{
	return x&(-x);
}

void add(int x, int y, int val)
{
	for (int i = x; i <= size; i += lowbit(i))
	{
		for (int j = y; j <= size; j += lowbit(j))
		{
			c[i][j] += val;
		}
	}
}

int sum(int x, int y)
{
	int sum = 0;
	for (int i = x; i > 0; i -= lowbit(i))
	{
		for (int j = y; j > 0; j -= lowbit(j))
		{
			sum += c[i][j];
		}
	}
	return sum;
}

void Init()
{
	memset(c, 0, sizeof(c));
	for (int i = 1; i <= size; i++)
	{
		for (int j = 1; j <= size; j++)
		{
			add(i, j, 1);
		}
	}
}

int main()
{
	int i;
	int T, cas = 1;
	cin >> T;
	while (T--)
	{
		char a;
		int x1, y1, x2, y2;
		int num;
		Init();
		scanf("%d", &n);
		printf("Case %d:\n", cas++);
		getchar();
		for (i = 1; i <= n; i++)
		{
			//用scanf %c 的话记得getchar()
			scanf("%c", &a);

			//下面坐标++是因为题目里说x,y是可以取到0的
			//但树状数组中下标不能为0,所以++
			//x1,y1 -1是考虑顶点,题目要求包含顶点
			if (a == 'S')
			{
				scanf("%d%d%d%d", &x1, &y1, &x2, &y2);
				x1++;
				y1++;
				x2++;
				y2++;
				if (x1 > x2)
					swap(x1, x2);
				if (y1 > y2)
					swap(y1, y2);
				int temp = sum(x2, y2) + sum(x1 - 1, y1 - 1) - sum(x2, y1 - 1) - sum(x1 - 1, y2);
				printf("%d\n", temp);
			}
			else if (a == 'A')
			{
				scanf("%d%d%d", &x1, &y1, &num);
				x1++;
				y1++;
				add(x1, y1, num);
			}
			else if (a == 'D')
			{
				scanf("%d%d%d", &x1, &y1, &num);
				x1++;
				y1++;
				int temp = sum(x1, y1) + sum(x1 - 1, y1 - 1) - sum(x1 - 1, y1) - sum(x1, y1 - 1);
				if (num > temp)
					num = temp;
				add(x1, y1, -num);
			}
			else if (a == 'M')
			{
				scanf("%d%d%d%d%d", &x1, &y1, &x2, &y2, &num);
				x1++;
				y1++;
				x2++;
				y2++;
				int temp = sum(x1, y1) + sum(x1 - 1, y1 - 1) - sum(x1 - 1, y1) - sum(x1, y1 - 1);
				if (num > temp)
					num = temp;
				add(x1, y1, -num);
				add(x2, y2, num);
			}
			getchar();
		}
	}
	return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值