hdu 4122 单调队列

http://acm.hdu.edu.cn/showproblem.php?pid=4122

Problem Description
The Mid-Autumn Festival, also known as the Moon Festival or Zhongqiu Festival is a popular harvest festival celebrated by Chinese people, dating back over 3,000 years to moon worship in China's Shang Dynasty. The Zhongqiu Festival is held on the 15th day of the eighth month in the Chinese calendar, which is in September or early October in the Gregorian calendar. It is a date that parallels the autumnal equinox of the solar calendar, when the moon is at its fullest and roundest. 

The traditional food of this festival is the mooncake. Chinese family members and friends will gather to admire the bright mid-autumn harvest moon, and eat mooncakes under the moon together. In Chinese, “round”(圆) also means something like “faultless” or “reuion”, so the roundest moon, and the round mooncakes make the Zhongqiu Festival a day of family reunion.

Alice has opened up a 24-hour mooncake shop. She always gets a lot of orders. Only when the time is K o’clock sharp( K = 0,1,2 …. 23) she can make mooncakes, and We assume that making cakes takes no time. Due to the fluctuation of the price of the ingredients, the cost of a mooncake varies from hour to hour. She can make mooncakes when the order comes,or she can make mooncakes earlier than needed and store them in a fridge. The cost to store a mooncake for an hour is S and the storage life of a mooncake is T hours. She now asks you for help to work out a plan to minimize the cost to fulfill the orders.
 

Input
The input contains no more than 10 test cases. 
For each test case:
The first line includes two integers N and M. N is the total number of orders. M is the number of hours the shop opens. 
The next N lines describe all the orders. Each line is in the following format:

month date year H R

It means that on a certain date, a customer orders R mooncakes at H o’clock. “month” is in the format of abbreviation, so it could be "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct", "Nov" or "Dec". H and R are all integers. 
All the orders are sorted by the time in increasing order. 
The next line contains T and S meaning that the storage life of a mooncake is T hours and the cost to store a mooncake for an hour is S.
Finally, M lines follow. Among those M lines, the i th line( i starts from 1) contains a integer indicating the cost to make a mooncake during the i th hour . The cost is no more than 10000. Jan 1st 2000 0 o'clock belongs to the 1 st hour, Jan 1st 2000 1 o'clock belongs to the 2 nd hour, …… and so on.

(0<N <= 2500; 0 < M,T <=100000; 0<=S <= 200; R<=10000 ; 0<=H<24)

The input ends with N = 0 and M = 0.
 

Output
You should output one line for each test case: the minimum cost. 
 

Sample Input
  
  
1 10 Jan 1 2000 9 10 5 2 20 20 20 10 10 8 7 9 5 10 0 0
 

Sample Output
  
  
70
Hint
“Jan 1 2000 9 10” means in Jan 1st 2000 at 9 o'clock , there's a consumer ordering 10 mooncakes. Maybe you should use 64-bit signed integers. The answer will fit into a 64-bit signed integer.
/**
hdu 4122 单调队列
题目大意:给定n个时刻,在每一个时刻都要生产ai个月饼。给出m个可以生产的时刻,每个时刻单个生产费用为bi,单个月饼可储存T时间,单位时间费用为S
         问如何安排生产花费最少
解题思路:用单调队列维护一个点之前所有点的最小花费(为生产费+储存费)
特别注意:n个时刻可能有重复的
*/
#include <string.h>
#include <algorithm>
#include <iostream>
#include <stdio.h>
#include <map>
using namespace std;
typedef long long LL;

map<string,int>mp;
int n,m,time[3050],sum[15],S,T,cost[100050],q[100050];
LL num[3000];

void init()
{
    mp["Jan"]=1,mp["Feb"]=2,mp["Mar"]=3,mp["Apr"]=4,mp["May"]=5,mp["Jun"]=6,mp["Jul"]=7,mp["Aug"]=8;
    mp["Sep"]=9,mp["Oct"]=10,mp["Nov"]=11,mp["Dec"]=12;
    sum[0]=0,sum[1]=31,sum[2]=sum[1]+28,sum[3]=sum[2]+31,sum[4]=sum[3]+30,sum[5]=sum[4]+31,sum[6]=sum[5]+30;
    sum[7]=sum[6]+31,sum[8]=sum[7]+31,sum[9]=sum[8]+30,sum[10]=sum[9]+31,sum[11]=sum[10]+30;
}

int get(int y,int m,int d,int t)
{
    int ans=0;
    for(int i=2000; i<y; i++)
    {
        if((i%4==0&&i%100!=0)||i%400==0)
            ans+=366;
        else
            ans+=365;
    }
    if((y%4==0&&y%100!=0)||y%400==0)
    {
        ans+=sum[m-1];
        if(m-1>=2)ans++;
    }
    else
    {
        ans+=sum[m-1];
    }
    ans+=(d-1);
    return ans*24+t;
}

int main()
{
    init();
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)break;
        for(int i=0; i<n; i++)
        {
            int year,day,t;
            char mon[10];
            scanf("%s%d%d%d%I64d",mon,&day,&year,&t,&num[i]);
            time[i]=get(year,mp[mon],day,t);
            //printf("->%d\n",time[i]);
        }
        scanf("%d%d",&T,&S);
        int tail=0,head=0,k=0;
        LL cnt=0;
        for(int i=0; i<m; i++)
        {
            scanf("%d",&cost[i]);
            while(head<tail&&cost[q[tail-1]]+S*(i-q[tail-1])>=cost[i])tail--;
            q[tail++]=i;
            while(i==time[k])
            {
                while(head+1<tail&&(i-q[head]>T))head++;
                //printf("%d==>>%d\n",i,q[head]);
                cnt+=num[k]*(cost[q[head]]+S*(i-q[head]));
                k++;
            }
        }
        printf("%I64d\n",cnt);
    }
    return 0;
}
/**
2 10
Jan 1 2000 2 10
Jan 1 2000 9 10
5 2
20
20
20
10
10
8
7
9
5
10
0 0
*/


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值