Numerically Speaking

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input

    
    
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output

    
    
45 59 6 13

题目就不翻译了,很简单。重量在比较深搜和广搜的区别

dfs做法

#include<iostream>
#include<cstring>
using namespace std;
char mark[20][20];
int w, h;
int num = 1;

void dfs(int x,int y,int i) {//i是用来控制方向的
 int dx[]= { 0,0,-1,1 };
 int dy[] = { 1,-1,0,0 };
 if (x + dx[i] >= w || x + dx[i] < 0|| y + dy[i] >= h || y + dy[i] < 0) return;
 else if (mark[x+dx[i]][y+dy[i]]=='#') return ;
 else {
  num++;
  mark[x + dx[i]][y + dy[i]] = '#';
  dfs(x + dx[i], y + dy[i], 0);
  dfs(x + dx[i], y + dy[i], 1);
  dfs(x + dx[i], y + dy[i], 2);
  dfs(x + dx[i], y + dy[i], 3);
 }
}
int main() {
 int x, y;
 while (cin>>w>>h&&w&&h)
 {
  num = 1;
  memset(mark,0,sizeof(mark));
  for (int j = 0; j < h; j++) {
  for (int i = 0; i < w; i++)
  {
    cin >> mark[i][j];
    if (mark[i][j] == '@') {
     x = i; y = j;
     mark[i][j] = '#';
    }

   }

  }
  //
  for (int i = 0; i < 4; i++)
   dfs(x, y, i);
  cout << num << endl;
 }
 return 0;
}

bfs做法:
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
char mark[21][21];
int num = 0;
int w, h;
struct node
{
 int x, y;
};

int main() {
 node fir, temp,then;
 queue<node> q;
 while (cin>>w>>h&&w&&h)
 {
  memset(mark,0,sizeof(mark));
  num =0;
  for (int j = 0; j < h; j++)
  {
   for (int i = 0; i < w; i++)
   {
    cin >> mark[i][j];
    if (mark[i][j] == '@') {
     fir.x = i; fir.y = j;
     mark[i][j] = '#';
    }
   }
  }
  q.push(fir);
  int dx[] = { 0,0,1,-1 };
  int dy[] = { 1,-1,0,0 };
  while (!q.empty())
  {
   num++;
   temp = q.front();
   q.pop();
   for (int i = 0; i < 4; i++)
   {
    then.x = temp.x + dx[i]; then.y = temp.y + dy[i];
    if (then.x  >= 0 && then.x  < w&& then.y >= 0 && then.y < h && mark[then.x][then.y] == '.')
    {
     mark[then.x][then.y] = '#';
     q.push(then);
    }
   }
  }
  cout << num << endl;
 }
 return 0;
}
顺便带一下queue的基本操作:
#include<queue>

申请队列:queue<type>q;

判队空:q.empty();

获取队头元素:q.front();

入队:q.push();

出队:q.pop();//STL自带的是没有返回值的

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值