K Best POJ 3111 (二分,最大化平均値)

K Best
Time Limit: 8000MS Memory Limit: 65536K
Total Submissions: 10565 Accepted: 2717
Case Time Limit: 2000MS Special Judge

Description

Demy has n jewels. Each of her jewels has some value vi and weight wi.

Since her husband John got broke after recent financial crises, Demy has decided to sell some jewels. She has decided that she would keep k best jewels for herself. She decided to keep such jewels that their specific value is as large as possible. That is, denote the specific value of some set of jewels S = {i1i2, …, ik} as

.

Demy would like to select such k jewels that their specific value is maximal possible. Help her to do so.

Input

The first line of the input file contains n — the number of jewels Demy got, and k — the number of jewels she would like to keep (1 ≤ k ≤ n ≤ 100 000).

The following n lines contain two integer numbers each — vi and wi (0 ≤ vi ≤ 106, 1 ≤ wi ≤ 106, both the sum of all vi and the sum of all wi do not exceed 107).

Output

Output k numbers — the numbers of jewels Demy must keep. If there are several solutions, output any one.

Sample Input

3 2
1 1
1 2
1 3

Sample Output

1 2

Source


分析:稍后


代码如下:

/* Author:kzl */
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
const int maxx = 100000;
const double EPS = 1e-6;
int n,k;
struct My{
int v,w;
}cun[maxx];
struct MM{
double val;
int id;
}aa[maxx];

bool cmp(MM a,MM b){
return a.val>b.val;
}

bool flag(double num,bool fl){
    double sum = 0;
for(int i=0;i<n;i++)
{
    aa[i].val = cun[i].v - num * cun[i].w;
    aa[i].id = i+1;
}
sort(aa,aa+n,cmp);
if(fl)printf("%d",aa[0].id);
for(int i=0;i<k;i++)
{
    sum+=aa[i].val;
    if(fl&&i)printf(" %d",aa[i].id);
}
if(fl)printf("\n");
if(sum>=0)return true;
else return false;
}


int main(){
while(scanf("%d%d",&n,&k)!=EOF)
{
    for(int i=0;i<n;i++)
    {
        scanf("%d%d",&cun[i].v,&cun[i].w);
    }
    double l = 0,r = 1e7,mid = 0;
    while(fabs(r-l)>EPS){
        mid = (l+r)/2.0;
        if(flag(mid,false))l = mid;
        else r = mid;
    }
    flag(mid,true);
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值