POJ 3666 Making the Grade (dp)

Making the Grade
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4404 Accepted: 2094

Description

A straight dirt road connects two fields on FJ's farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, ... , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . ... , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

| A B 1| + | A B 2| + ... + | AN -  BN |

Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single integer elevation: Ai

Output

* Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

Sample Input

7
1
3
2
4
5
3
9

Sample Output

3

dp[i][j]表示第i个位置的值改成b数组中第j个数的值,且前i个有序(单调不上升或者单调不下降)
dp[i][j] = min (dp[i - 1][k])+ abs (a[i] - b[j])     最小的dp[i - 1][k]可以边循环边找,且k<=j

然后分别做一次就可以了

AC代码如下:

//
//  POJ 3666 Making the Grade
//
//  Created by TaoSama on 2015-03-06
//  Copyright (c) 2015 TaoSama. All rights reserved.
//
#include <algorithm>
#include <cctype>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <map>
#include <queue>
#include <string>
#include <set>
#include <vector>
#define CLR(x,y) memset(x, y, sizeof(x))

using namespace std;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9 + 7;
const int N = 1e5 + 10;

//dp[i][j]表示第i个位置的值改成b数组中第j个数的值,且前i个有序(单调不上升或者单调不下降)
//dp[i][j] = min (dp[i - 1][k])+ abs (a[i] - b[j])
//最小的dp[i - 1][k]可以边循环边找,且k<=j

int n, a[2005], b[2005], dp[2005];
int solve() {
	memset(dp, 0, sizeof dp);
	for(int i = 1; i <= n; ++i) {
		int preMin = INF;
		for(int j = 1; j <= n; ++j) {
			preMin = min(preMin, dp[j]);
			dp[j] = preMin + abs(a[i] - b[j]);
		}
	}
	return *min_element(dp + 1, dp + 1 + n);
}

int main() {
#ifdef LOCAL
	freopen("in.txt", "r", stdin);
//	freopen("out.txt","w",stdout);
#endif
	ios_base::sync_with_stdio(0);

	while(cin >> n) {
		for(int i = 1; i <= n; ++i) cin >> a[i], b[i] = a[i];

		sort(b + 1, b + 1 + n);
		int ans = INF;
		ans = min(ans, solve());
		reverse(b + 1, b + 1 + n);
		ans = min(ans, solve());
		cout << ans << endl;
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值