杭电acm P2024C语言的合法标识符

C语言合法标识符
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 80596 Accepted Submission(s): 31104

Problem Description
输入一个字符串,判断其是否是C的合法标识符。

Input
输入数据包含多个测试实例,数据的第一行是一个整数n,表示测试实例的个数,然后是n行输入数据,每行是一个长度不超过50的字符串。

Output
对于每组输入数据,输出一行。如果输入数据是C的合法标识符,则输出”yes”,否则,输出“no”。

Sample Input
3
12ajf
fi8x_a
ff ai_2

Sample Output
no
yes
no

import java.util.Scanner;
public class P2024 {
  public static void main(String[] args) {
      Scanner sc=new Scanner(System.in);
      while(sc.hasNext()){
      String str=sc.nextLine();
      int n = Integer.parseInt(str);
      while(n-->0){ 
          str=sc.nextLine();
           int j=0;
           if(str.charAt(0)>='a'&&str.charAt(0)<='z'||str.charAt(0)>='A'&&str.charAt(0)<='Z'||str.charAt(0)=='_'){
                for(j=0;j<str.length();j++){
                   if(str.charAt(j)>='a'&&str.charAt(j)<='z'||str.charAt(j)>='A'&&str.charAt(j)<='Z'||str.charAt(j)=='_'||str.charAt(j)>='0'&&str.charAt(j)<='9'){
                      continue;
                   }else{
                       break;
                   }

               }
                   if(j==str.length()){
                       System.out.println("yes");
                   }else{
                       System.out.println("no");
                   }
           }else{
               System.out.println("no");
                }
          }
      }
  }
}

/*
* sc.nextInt(): 只接收整数,,整数后面的换行符还留在流内不读出来
* sc.next(): 接收到空白符就丢,直到接收到一个非空白符的字符串,以遇到下一个空白符为停止标记
* sc.nextLine(): 接收到换行符就停,把换行符及前面部分从流中取出来, 把换行符丢掉,剩下的部分就是返回值
*/

第二种方法:

import java.util.Scanner;
public class P2024 {
   public static void main(String[] args) {
      Scanner sc=new Scanner(System.in);
      while(sc.hasNext()){
      int n=sc.nextInt();
      String str=sc.nextLine();
      while(n-->0){ 
           str=sc.nextLine();
           int j=0;
           if(str.charAt(0)>='a'&&str.charAt(0)<='z'||str.charAt(0)>='A'&&str.charAt(0)<='Z'||str.charAt(0)=='_'){
                for(j=0;j<str.length();j++){
                   if(str.charAt(j)>='a'&&str.charAt(j)<='z'||str.charAt(j)>='A'&&str.charAt(j)<='Z'||str.charAt(j)=='_'||str.charAt(j)>='0'&&str.charAt(j)<='9'){
                      continue;
                   }else{
                       break;
                   }

               }
                   if(j==str.length()){
                       System.out.println("yes");
                   }else{
                       System.out.println("no");
                   }
           }else{
               System.out.println("no");
                }
          }
      }
  }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值