数据结构之二叉树的遍历 HDU1710 Binary Tree Traversals

Binary Tree Traversals

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3482    Accepted Submission(s): 1559


Problem Description
A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
 

Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
 

Output
For each test case print a single line specifying the corresponding postorder sequence.
 

Sample Input
  
  
9 1 2 4 7 3 5 8 9 6 4 7 2 1 8 5 9 3 6
 

Sample Output
  
  
7 4 2 8 9 5 6 3 1
 

Source
HDU 2007-Spring Programming Contest
我们来分析先序遍历和中序遍历的特点,先序遍历是 根 左节点 右节点  中序遍历 是左节点 根 右节点
这样我们可以利用递归的思想,在in数组中找到根,那么根的左边必为当前根的左子树,根的右边必为右子树,我们先遍历左子树直到最后该节点没有儿子为止!
#include<iostream>
#include<stack>
#include<cstdio>
#define mnum 1020
using namespace std;
int pre[mnum],in[mnum],vis_pre[mnum],vis_in[mnum];
stack<int> zhan;
void find(int root_pre,int root_in,int n,int flag)
{	if(n==1)//只能存在一个
	{
		cout<<pre[root_pre]<<" ";
		return;
	}
	else if(n<=0)
	{
		return;
	}
	int i;
	for( i=0;pre[root_pre]!=in[root_in+i];i++);
	find(root_pre+1,root_in,i,0);   //左子树的遍历,pre数组某元素的右边必为其左子树(除非找不到了左子树)  i是左节点能够取到的最大值
	find(root_pre+i+1,root_in+i+1,n-i-1,0);
	if(flag) cout<<pre[root_pre]<<endl;
	else cout<<pre[root_pre]<<" ";
}
int main()
{	freopen("input.txt","r",stdin);
	int n;
	while(cin>>n)
	{
		for(int i=1;i<=n;i++)
		{
			cin>>pre[i];
		}
		for(int i=1;i<=n;i++)
		cin>>in[i];
		find(1,1,n,1);
	}
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值