poj 2828 Buy Tickets -插队问题-单节点更新-线段树

Buy Tickets

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The nextN lines contain the pairs of values Posi andVali in the increasing order ofi (1 ≤ iN). For each i, the ranges and meanings ofPosi and Vali are as follows:

  • Posi ∈ [0, i − 1] — Thei-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — Thei-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

题目大意

插队


解题思路

链表会超时,神奇的线段树能解决问题。

线段数每个节点有的属性: 区间,存放的值,还剩几个位置没被占

线段树的叶子节点应该是刚刚好全被占用。

因为是插队,所以后面选位置的人先决定位置,而倒数第二个选同一个位置的人将被挤到下一个位置,所以我们可以倒序处理位置

一个节点一个位置,所以,每个人站的位置一定 >= 他想占的位置。

假如每个位置都空,那么最后一个想坐到3号位置的人可以直接坐进去,倒数第二个想做到3号的人就被挤到下一个位置了

这里用一个很神奇的 处理 巧妙地解决了这个问题,

如果左儿子剩余空间比位置小,那么必然是没找到位置或者是位置被占过了,也就是说当前这个人前面有人插队,把自己的位置后移了,插队了n个人则位置后移n位

那么就得往右儿子找,但找的时候要减去左儿子的剩余空间数。

如果没被插队,应当 减去左儿子区间长度。 例如 左儿子是1~5,右儿子是6~10,pos是6 左儿子区间长度 = 5;那么应当插在右儿子的第 (pos-左儿子区间长度) = 1个位置,即6号位。如果被n个人插了队,那么位置应该变为pos - 左儿子区间长度 + n = pos-(左儿子区间长度-n)。而我们先线段树的tree【node】.sum 维护的就是左儿子区间长度-n.


比如左儿子区间是1~3 右儿子区间是4~5,最后一个人要去3号 倒数第二个人也要去3号,那么最后一个人站稳了3号,左儿子剩余位置为2,

倒数第二个人应当去4号位置,也就是右儿子的第一个位置。3-2 = 1,右边第一个位置


代码:

#include <iostream>
#include <cstdio>

using namespace std;


struct mnode
{
    int l,r,sum,val;//左右区间,空位置数,数值
}tree[200010*4];

void buildtree(int node,int b,int e)
{
    tree[node].l = b;
    tree[node].r = e;
    tree[node].val = 0;
    tree[node].sum = e-b+1;

    if(b==e) return ;

    int mid = (b+e)/2;
    if(b<=mid) buildtree(node*2,b,mid);
    if(e>mid) buildtree(node*2+1,mid+1,e);
}

void update(int node,int pos,int data)
{
    if(tree[node].l==tree[node].r)
    {
        tree[node].val = data;
        tree[node].sum--;
        return;
    }
    if(pos<=tree[node*2].sum) update(node*2,pos,data);
    else update(node*2+1,pos-tree[node*2].sum,data);
    tree[node].sum = tree[node*2].sum+tree[node*2+1].sum;
}
int ans[200010];
int num=0;
void myprint(int node)
{
    if(tree[node].l==tree[node].r)
    {
        ans[num++] = tree[node].val;
        return ;
    }
    myprint(node*2);
    myprint(node*2+1);
}
int  main()
{
    int n;
    int p[200010];
    int v[200010];
    while(scanf("%d",&n)!=EOF)
    {
        num=0;
        buildtree(1,1,n);
        for(int i=0;i<n;++i)
        {
            scanf("%d%d",&p[i],&v[i]);
        }
        for(int i = n-1;i>=0;--i)
        {
            update(1,p[i]+1,v[i]);
        }
        myprint(1);

        for(int i=0;i<n-1;++i)
            printf("%d ",ans[i]);
        printf("%d\n",ans[n-1]);
    }

    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值