hdu 1856 More is better 并查集

More is better

                                                                   Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
  
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 
   题意:王老师要找一些男生帮助他完成一项工程。要求最后挑选出的男生之间都是朋友关系,可以说直接的,也可以是间接地。问最多可以挑选出几个男生(最少挑一个)。
         这是一个有关并查集的题目。只不过不是求有几个集合,而是求每个集合中元素的个数,进而求出个数的最大值。和求集合个数的方法差不多,只需要在合并两个集合时处理一下,让这两个集合的元素个数也合并一下就行了。接下来只需要找出最大值即可。要注意的一个地方就是:当n=0时,要输出1。

代码如下:
#include<stdio.h>
#define N 10000000
int father[N],num[N];
void initial()/*初始化*/
{
	int i;
	for(i=1;i<=N;i++)
	{
		father[i]=i;
		num[i]=1;/*开始时数量都为1,根节点为自己*/
	}
}
int find(int x) /*寻找根节点*/
{
	if(father[x]!=x)
		father[x]=find(father[x]);
	return father[x];
}
void merge(int a,int b)/*合并a和b*/
{
	int p=find(a);
	int q=find(b);
	if(p!=q)
	{
		father[p]=q;
		num[q]+=num[p];/*合并集合中元素个数*/
	}
}
int main()
{
	int n,a,b,i,sum,max;
	while(~scanf("%d",&n))
	{
		if(n==0)
		{
			printf("1\n");
			continue;
		}
		max=0;
		initial(); /*初始化*/
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&a,&b);
			if(a>max)
				max=a;
			if(b>max)
				max=b;
			merge(a,b); /*合并集合*/
		}
		int Max=0;
		for(i=1;i<=max;i++)
			if(num[i]>Max) /*查找最大值*/
				Max=num[i];
		printf("%d\n",Max);
	}
	return 0;
}


  • 6
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值