1130. Infix Expression (25)
Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N ( <= 20 ) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:
data left_child right_child
where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by -1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.
|
|
|
|
Output Specification:
For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.
Sample Input 1:8 * 8 7 a -1 -1 * 4 1 + 2 5 b -1 -1 d -1 -1 - -1 6 c -1 -1Sample Output 1:
(a+b)*(c*(-d))Sample Input 2:
8 2.35 -1 -1 * 6 1 - -1 4 % 7 8 + 2 3 a -1 -1 str -1 -1 871 -1 -1Sample Output 2:
(a*2.35)+(-(str%871))
这题参考2017 408数据结构大题41
#include<stdio.h>
struct node{
char s[15];
int left;
int right;
}tree[25];
int findroot[25];
void inorder(int root,int depth){
if(root!=-1){
if(tree[root].left==-1&&tree[root].right==-1){//叶子结点直接输出
printf("%s",tree[root].s);
}
else{
if(depth>1){//根节点不用括号
printf("(");
}
inorder(tree[root].left,depth+1);
printf("%s",tree[root].s);
inorder(tree[root].right,depth+1);
if(depth>1){//根节点不用括号
printf(")");
}
}
}
}
int main(){
int n,i,root;
scanf("%d",&n);
for(i=1;i<=n;i++){
scanf("%s %d %d",tree[i].s,&tree[i].left,&tree[i].right);
if(tree[i].left!=-1){
findroot[tree[i].left]=1;
}
if(tree[i].right!=-1){
findroot[tree[i].right]=1;
}
}
for(i=1;i<=n;i++){
if(findroot[i]==0){
root=i;break;
}
}
inorder(root,1);
}