POJ 2000 Gold Coins

Gold Coins
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 22762 Accepted: 14266

Description

The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of the next two days (the second and third days of service), the knight receives two gold coins. On each of the next three days (the fourth, fifth, and sixth days of service), the knight receives three gold coins. On each of the next four days (the seventh, eighth, ninth, and tenth days of service), the knight receives four gold coins. This pattern of payments will continue indefinitely: after receiving N gold coins on each of N consecutive days, the knight will receive N+1 gold coins on each of the next N+1 consecutive days, where N is any positive integer. 

Your program will determine the total number of gold coins paid to the knight in any given number of days (starting from Day 1). 

Input

The input contains at least one, but no more than 21 lines. Each line of the input file (except the last one) contains data for one test case of the problem, consisting of exactly one integer (in the range 1..10000), representing the number of days. The end of the input is signaled by a line containing the number 0.

Output

There is exactly one line of output for each test case. This line contains the number of days from the corresponding line of input, followed by one blank space and the total number of gold coins paid to the knight in the given number of days, starting with Day 1.

Sample Input

10
6
7
11
15
16
100
10000
1000
21
22
0

Sample Output

10 30
6 14
7 18
11 35
15 55
16 61
100 945
10000 942820
1000 29820
21 91
22 98

Source

感觉是第二次做这个题了,注意要用long long,还是先打表两层for循环,第一层是循环的钱数,粗略算了一下(等差数列求和),到500就行,第二层用while,以i为循环次数,然后赋给数组a就好了

ac代码:

#include <stdio.h>

int main()
{
	long long i,j=1,n,tmp;
	long long a[10001];
	
	for(i=1;i<200;i++)
	{
		tmp=i;
		while(tmp--)
		{
			if(j>=10001)
				break;
				
			a[j++]=i;
		}
	}
	for(i=2;i<10001;i++)
	{
		a[i]=a[i]+a[i-1];
	}
	
	while(scanf("%I64d",&n),n)
	{
		printf("%I64d %I64d\n",n,a[n]);
	}
	
	return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值