杭电1005 Number Sequence问题

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 116819    Accepted Submission(s): 28424

    这题简直不能叫编程题,看到网上很多代码认为循环周期为48,或是循环里必然包括1、1,这都不科学!
Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

Author
CHEN, Shunbao
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1008  1021  1019  1009  1012 
 




   
   
#include <stdio.h>
 
/**程序首先记录1到100之间的值,根据数论得到循环周期小于49(原因不详),
* 从60之前找到循环的位置
* 注意:循环不一定包括1、1!654 987 6163 测试得循环里不包含1、1
 
*/
int main()
{
int f[100];
int A,B,N;
int begin;
int cycle;//循环周期
int result;//最后结果的位置
while(1)
{
scanf("%d%d%d",&A,&B,&N);
if(A==0 && B==0 && N==0)
break;
f[0] = 1;
f[1] = 1;
 
int i;
for(i=2; i<100; i++)
{
f[i] = (A*f[i-1] + B*f[i-2]) % 7;
 
}
for(i = 3; i<100; i++)
{
if(f[i]==f[60] && f[i+1]==f[61])
break;
}
 
cycle = 60-i;
if(N>100)
result = (N-1-i)%cycle+i;
else
result = N-1;
 
printf("%d\n",f[result]);
 
}
 
return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值