在FC4下编译安装chmsee

原创 2006年06月06日 13:20:00
      chmsee 是在linux下一款查看chm文件的工具. 当前的最新版本为0.9.6-RC2. 编译最新的chmsee时,需要gtk2.8以上,gtkhtml,chmlib等库.在摸索半天后,成功安装.把安装过程简述如下:
     1. 下载源码
          a. http://gro.clinux.org/projects/chmsee/  下载最新的chmsee源码.
          b. 在www.gtk.org 下载 gtk2.8 以及相关的依赖包
                cairo-1.0.2.tar.gz 
                libpng-1.2.8.tar.bz2   
                tiff-3.7.4.tar.gz
                jpegsrc.v6b.tar.gz 
                pkg-config-0.20.tar.gz(注:如果当前的pkg-config版本已经是2.0的版本,就不必下这个包了. 验证方法: pkg-config --version)
                atk-1.10.3.tar.bz2 
                glib-2.8.6.tar.bz2 
                pango-1.10.4.tar.bz2
                gtk+-2.8.18.tar.bz2
           c.   在http://ftp.gnome.org/pub/GNOME/sources/ 下载gtkhtml , gnome-icon-theme
                gnome-icon-theme-1.3.7.tar.bz2
                gtkhtml-3.8.2.tar.bz2
           d.   在http://66.93.236.84/~jedwin/projects/chmlib/ 下载CHMLib
                chmlib-0.37.4.tgz
    2.  解压宿下载的软件包.
    3.  编译
         a. 先编译gtk2.8
             分别编译安装
cairo-1.0.2  libpng-1.2.8  tiff-3.7.4 jpegsrc.v6b .
              有一点要注意的是,如果编译的时候使用的是默认配置,那么在编译安装完后,应该在~/.bashrc 为PKG_CONFIG_PATH指定值.
              export PKG_CONFIG_PATH="/usr/local/lib/pkgconfig"
              export LD_LIBRARY_PATH="/usr/local/lib"
             然后按顺序编译安装atk,pango,glib, gtk+-2.8
         b. 编译安装gnome-icon-theme,gkthtml
         c.  编译安装chmlib
         d. 最后编译安装chmsee.
         以上所有软件包的编译安装指令就3条.按顺序是
         ./configure
         make
         make install  
         关键是要配置 PKG_CONFIG_PATH,和 LD_LIBRARY_PATH的值.否则在后续的编译过程中会出现错误.



linux下chm阅读器的安装与使用

Fedora Core 下的chm阅读器有好几个,xchm、chmsee、kchmviewer、gnochm、chmreader、fbreader。     1、gnochm     gnochm...
  • nieshanfeng1
  • nieshanfeng1
  • 2014年02月19日 11:12
  • 1697

centos6.0桌面配置

作者:audered 转自:http://blog.csdn.net/audered/article/details/6661091 进入系统第一件事更新系统 1.yum updat...
  • whw8007
  • whw8007
  • 2013年05月27日 22:48
  • 520

编译安装详解和rpm和yum

1. 程序包管理器的功能     我们知道,由程序员编写并提供的程序源代码要转换成目标二进制格式才能在计算机上运行起来,但用户要在平台上使用时需要手动编译安装后才能使用,对于普通用户来说有一定...
  • chengxuyuanyonghu
  • chengxuyuanyonghu
  • 2017年03月13日 15:59
  • 1839

php7源码编译安装

以下以CentOS 7.2为例,安装php的运行环境,首先打开php官网http://php.net/点击导航栏的Downloads进入下载页面:http://php.net/downloads.ph...
  • u014574478
  • u014574478
  • 2017年05月19日 20:05
  • 2483

Zabbix3.04 编译安装

系统类型及版本:                centos7.2        zabbix3.04 1.安装zabbix3.04所需要的依赖包 yum -y install gcc gcc-c++...
  • tianhua79658788
  • tianhua79658788
  • 2016年09月14日 11:36
  • 1472

php编译安装与配置

php编译安装与配置 =========================================== 官网:http://php.net/ 官网下载:http://php.net/downlo...
  • u010861514
  • u010861514
  • 2016年07月16日 21:38
  • 14956

linux CentOS7.2---编译安装环境

转自http://www.centoscn.com/CentosServer/www/2014/0904/3673.html 和 http://www.cnblogs.com/longfeiPHP/...
  • Ghost_hell
  • Ghost_hell
  • 2017年01月05日 20:59
  • 2037

squid3.5.5的编译安装

1.Squid是什么?   Squid是一个单进程的异步代理缓存服务器,支持HTTP,FTP,GOPHER,ICP等协议。通过配置,可以实现反向代理、透明代理的功能,并且支持缓存,是实现高性能网站...
  • liuxiaolei86
  • liuxiaolei86
  • 2015年07月03日 14:16
  • 4355

Linux下编译安装apache

内容转载自:http://www.cnblogs.com/alexqdh/archive/2012/11/20/2764810.html 首先注明下面的操作都是在root下执行或者使...
  • yang449605460
  • yang449605460
  • 2014年11月15日 20:39
  • 1015

hbase在hadoop2.2.0编译安装,及常见问题

我的环境是: hadoop 2.2.0  hbase 0.94.11 有5台机器: baby19,baby18,baby17,baby16,baby15 一. 编译; 1. 下载hbase,解压 ...
  • teddeyang
  • teddeyang
  • 2013年11月12日 17:11
  • 3243
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:在FC4下编译安装chmsee
举报原因:
原因补充:

(最多只允许输入30个字)