ZOJ - 2319 Beautiful People(dp+STL)

Beautiful People

Time Limit: 5 Seconds       Memory Limit: 32768 KB       Special Judge

The most prestigious sports club in one city has exactly N members. Each of its members is strong and beautiful. More precisely, i-th member of this club (members being numbered by the time they entered the club) has strength Si and beauty Bi. Since this is a very prestigious club, its members are very rich and therefore extraordinary people, so they often extremely hate each other. Strictly speaking, i-th member of the club Mr X hates j-th member of the club Mr Y if Si <= Sj and Bi >= Bj or if Si >= Sj and Bi <= Bj (if both properties of Mr X are greater then corresponding properties of Mr Y, he doesn��t even notice him, on the other hand, if both of his properties are less, he respects Mr Y very much).

To celebrate a new 2005 year, the administration of the club is planning to organize a party. However they are afraid that if two people who hate each other would simultaneouly attend the party, after a drink or two they would start a fight. So no two people who hate each other should be invited. On the other hand, to keep the club prestige at the apropriate level, administration wants to invite as many people as possible.

Being the only one among administration who is not afraid of touching a computer, you are to write a program which would find out whom to invite to the party.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


Input

The first line of the input file contains integer N - the number of members of the club. (2 <= N <= 100 000). Next N lines contain two numbers each - Si and Bi respectively (1 <= Si, Bi <= 109).


Output

On the first line of the output file print the maximum number of the people that can be invited to the party. On the second line output N integers - numbers of members to be invited in arbitrary order. If several solutions exist, output any one.


Sample Input

1

4
1 1
1 2
2 1
2 2


Sample Output

2
1 4

题意:给出n个人,每个人有一个s值和b值,如果满足条件s[i]<=s[j]&&b[i]>=b[j]或s[i]>=s[j]&&b[i]<=b[j],则两人相互讨厌,转化一下可得 Si < Sj && Bi < Bj时两人不相互讨厌,先将s增序排列,当s相等时,b减序,当S相同时之所以要对B减序,是因为如果S递增的话,那么选出的方案中会将S相同的几个人都包含进去,不符合题目要求。然后就用O(nlogn)的算法求最长上升子序列的同时,记录到达每一个数时的最大长度。最后从最大长度向下输出路径即可。
#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=100005;
int dp[N];//最长上升子序列长度为i时子序列末尾的最小b值 
int mark[N];//以第i个人结尾的最长公共子序列的长度
struct node
{
    int s,b;
    int id;
    bool friend operator <(node a,node b)
    {
        if(a.s==b.s)return a.b>b.b;
        return a.s<b.s;
    }
}a[N];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&a[i].s,&a[i].b);
            a[i].id=i;
        }
        sort(a+1,a+n+1);
        int max_len=0;
        dp[++max_len]=a[1].b;
        mark[1]=max_len;
        for(int i=2;i<=n;i++)
        {
            if(dp[max_len]<a[i].b)
            {
                dp[++max_len]=a[i].b;
                mark[i]=max_len;
            }
            else
            {
                int k=lower_bound(dp+1,dp+1+max_len,a[i].b)-dp;
                dp[k]=a[i].b;
                mark[i]=k;
            }
        }
        printf("%d\n",max_len);
        for(int i=n;i>=1;i--)
        {
            if(mark[i]==max_len)
            {
                printf("%d",a[i].id);
                if(max_len>1)printf(" ");
                max_len--;
            }
        }
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值