HDU-2639-Bone Collector II(01背包的第k优解)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2639

Bone Collector II

Problem Description
The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
12 2 0
 

01背包求最优解的状态转移方程:dp[i][v]=max{dp[i-1][v],dp[i-1][v-cost[i]]+value[i]}。如果要求第k优解,那么状态dp[i][v]就应该是一个大小为k的数组f[i][v][1..K]。其中dp[i][v][k]表示前i个物品、背包大小为 v时,第k优解的值。用两个数组存储放与不放的情况,那么,求第k优解等价于对两个由大到小的数组的合并选出前k大的。另外还要注意题目对于“第K优解”的定义,将方法不同但结果相同的两个方案是看作同一个解还是不同的解。如果是看作同一个解,则要保证数组里的数没有重复的。

在网上看了一个很形象的比喻:如果我想知道学年最高分,那么,我只要知道每个班级的最高分,然后统计一遍就可以了。如果我想知道学年前十呢?我必须要知道每个班的前十名。这就是本题核心的算法。两种决策,就可以看作这个学年只有两个班。

代码如下:

#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    int T,i,j,t,n,v,k,value[111],cost[111],dp[1111][111],a[111],b[111];
    cin>>T;
    while(T--)
    {
        cin>>n>>v>>k;
        for(i=1;i<=n;i++)
        cin>>value[i];
        for(i=1;i<=n;i++)
        cin>>cost[i];
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++)
        {
            for(j=v;j>=cost[i];j--)
            {
                for(t=1;t<=k;t++)//将放入与不放入的情况放入两个数组中存储,这两个数组各自的前k大的值。 
                {
                    a[t]=dp[j-cost[i]][t]+value[i];
                    b[t]=dp[j][t];
                } 
                int x=1,y=1,z=1;
                a[t]=b[t]=-1;
                //dp[j][k]=max_kth(dp[j][1],dp[j][2]...dp[j][k],dp[j-cost[i]][1]+value[i],...dp[j-cost[i]][k]+value[i]);
                for(z=1;z<=k&&(a[x]!=-1||b[y]!=-1);)//循环找出前k个的最优解 ,合并这两个数组并选出前k个最大的。 
                {
                    if(a[x]>b[y])
                    {
                        dp[j][z]=a[x];
                        x++;
                    }
                    else
                    {
                        dp[j][z]=b[y];
                        y++;
                    }
                    if(dp[j][z]!=dp[j][z-1])//去重 
                    z++;
                }
            }
        }
        cout<<dp[v][k]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值