最小生成树 poj 2395 Out of Hay

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She’ll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1.

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she’s only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry.

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she’ll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she’ll have to traverse.
Input
* Line 1: Two space-separated integers, N and M.

  • Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.
    Output
  • Line 1: A single integer that is the length of the longest road required to be traversed.
    Sample Input
    3 3
    1 2 23
    2 3 1000
    1 3 43
    Sample Output
    43
    Hint
    OUTPUT DETAILS:

In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.

经鉴定,这是一道单纯的kuskal,别想太多,记录一下最大边就行,开始时说所有农场都和第一个农场相连这个条件没什么用。不是最大流,感动。

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstring>
#include<queue>
#include<iostream>
//#include<random>
#include<functional>
#include<list>
#include<cstdlib>
#include<stdlib.h>
#include<vector>
#define lld long long int
#define INF 0x7fffffff
using namespace std;

struct edge
{
    int u, v, c;
}es[10020];
int parent[10020];
int h[10020];
int n, m;

bool comp(edge a,edge b)
{
    return a.c < b.c;
}
void init()
{
    for (int i = 0;i < n;i++)
    {
        parent[i] = i;
        h[i] = 0;
    }
}
int find(int x)
{
    if (parent[x] == x)return x;
    else return parent[x] = find(parent[x]);
}

void unite(int a, int b)
{
    int x = find(a);
    int y = find(b);
    if (h[x] > h[y]) parent[y] = x;
    else
    {
        parent[x] = y;
        if (h[x] == h[y])h[y]++;
    }
}

bool same(int x, int y)
{
    return find(x) == find(y);
}

int main()
{
    while (~scanf("%d%d", &n, &m))
    {
        for (int i = 0;i < m;i++)
        {
            int a, b, c;
            scanf("%d%d%d", &a, &b, &c);
            a--;b--;
            es[i].u = a;
            es[i].v = b;
            es[i].c = c;
        }
        sort(es, es + m, comp);
        init();
        int maxn = 0;
        for (int i = 0;i < m;i++)
        {
            if (!same(es[i].u, es[i].v))
            {
                unite(es[i].u, es[i].v);
                maxn = max(maxn, es[i].c);
            }
        }
        printf("%d\n", maxn);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值