ZOJ 3870 Team Formation

题目链接

Team Formation

Time Limit: 3 Seconds      Memory Limit: 131072 KB

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team fromN students of his university.

Edward knows the skill level of each student. He has found that if two students with skill levelA and B form a team, the skill level of the team will be A B, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e.AB > max{A, B}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line containsN positive integers separated by spaces. The ith integer denotes the skill level ofith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input
2
3
1 2 3
5
1 2 3 4 5
Sample Output
1
6

题意:n个数,求n个数中两个数异或起来比两个数都大的数有多少对?

题解:枚举每一个数x,求解比X小的数中,与X异或起来大于X的数的数目。

若X^Y>X,X>Y。若Y的二进制最高位为i,则X二进制的第i为一定为0。

因此,我们可以预处理出所有数的最高位,并统计出最高位i的数的数目。

枚举每一个数X,再枚举X二进制中每一个位,若这一位低于X的最高位,且这一位为0,则答案加上最高位为这一位的数的数目。

代码如下:

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<iostream>
#include<string>
#include<map>
using namespace std;
typedef long long LL;
const int mmax = 100010;
int n;
int a[mmax];
LL num[35];
int main()
{
    int i,j;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        memset(num,0,sizeof(num));
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            for(j=31;j>=0;j--)
            {
                if((1<<j)&a[i])
                {
                    num[j]++;
                    break;
                }
            }
        }
        sort(a+1,a+n+1);
        LL ans=0;
        int ix;
        for(i=n;i>=1;i--)
        {
            ix=-1;
            for(j=31;j>=0;j--)
            {
                if((1<<j)&a[i])
                {
                    if(ix==-1)
                        ix=j;
                    continue;
                }
                ans+=num[j];
            }
            if(ix!=-1)
                num[ix]--;
        }
        printf("%lld\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值