linux(Centos)下编译安装gcc4.8.2

原创 2015年07月09日 12:58:48

欢迎转载,转载请注明原文地址:http://blog.csdn.net/majianfei1023/article/details/46811159


最近要用到c++ 11,所以没办法只得把那台centos6.6的gcc4.4.7升级一下。

gcc编译器已经出到5.1了,但是我对最新的版本并没有特别大的兴趣,更喜欢稳定性的版本。

gcc4.8.1 是第一个完全支持C++11 的编译器,我这边装的是4.8.2.


一、获取gcc4.8.2包并解压缩:

下载链接:http://gcc.skazkaforyou.com/releases 

里面有gcc所有的版本,自行下载。

也可以选择: wgethttp://gcc.skazkaforyou.com/releases/gcc-4.8.2/gcc-4.8.2.tar.gz


然后解压缩: tar -zxvf gcc-4.8.2.tar.gz


二、安装依赖库:
进入gcc-4.8.2目录,执行./contrib/download_prerequisities脚本会自动下载三个依赖库别为gmp-4.3.2mpfr-2.4.2mpc-0.8.1

或者自己手动下载:
ftp://ftp.gnu.org/gnu/gmp/gmp-4.3.2.tar.bz2
http://www.mpfr.org/mpfr-2.4.2/mpfr-2.4.2.tar.bz2
http://www.multiprecision.org/mpc/download/mpc-0.8.1.tar.gz


然后就是机械的安装过程了。


cd gmp
./configure --prefix=/usr
sudo make && make install


cd mpfr
./configure --prefix=/usr
sudo make && make install


cd mpc
./configure --prefix=/usr
sudo make && make install



注:g++ -v 可以看到系统原有的gcc的安装目录 即--prefix变量的值(一般是/user或者/user/local),你自己安装的时候配置跟它一样是最好的了,这样最方便。

如果编译的时候是自定义指定的安装路径,那你就要把lib目录放到ld.so.conf里面并执行ldconfig了。

如果还不行,在编译 gcc 时需要加上下面的选项:
--with-mpc=MPC的安装目录
--with-mpfr=MPFR的安装目录
--with-gmp=GMP的安装目录


三、编译安装GCC4.8.2
./configure --prefix=/usr --enable-threads=posix --disable-checking --enable-languages=c,c++ --disable-multilib 
sudo make && make install


gcc的参数配置:
--prefix                  //默认gcc的安装目录,最好跟原有的gcc的安装目录一致
--disable-checking        //生成的编译器在编译过程中不做额外检查,也可以使用--enable-checking=xxx来增加一些检查;
--enable-languages        //指定gcc能编译哪些语言的文件,每种语言用逗号分隔, 例如 c,c++,java

--disable-multilib        //默认gcc能在32位系统上将代码编译成64位程序,或者在64位系统上编译成32位程序,如果加上这个编译选项则表示关闭这个gcc的交叉编译功能。


注:如果你不是装在/usr 或者 /user/local 那么链接到对应的目录下就行了。


四、测试成功

查看gcc -v发现已经成功更新到4.8.2

执行一个示例:

#include <iostream>
#include <vector>
 
int main()
{
	int arr[] = {2,4,6,8,10};
	size_t count=sizeof(arr)/sizeof(arr[0]);
	std::vector<int> vec(arr,arr + count);
	//for (std::vector<int>::iterator iter = vec.begin(); iter != vec.end(); ++iter)
	for (auto iter = vec.begin(); iter != vec.end(); ++iter)
	{
		std::cout<<*iter<<std::endl;
	}
	return 0;
}



g++ cpp11.cpp -o cpp11-std=c++11

如果不加-std=c++11就会编译错误,因为没办法识别auto iter,这是c++11才有的语法。

CentOS升级gcc4.4.7到gcc4.8.5

最近想要升级gcc,因为CentOS6.7默认自带的编译器是gcc 4.4.7,但是不支持c++11,所以我想升级到gcc 4.8.5,这样就可以完全支持c++11了。gcc官网上面说从gcc 4.8...
  • shine_journey
  • shine_journey
  • 2017年03月14日 11:30
  • 5458

Redhat 6.6离线升级gcc-4.8

一.背景由于项目需要,必须在redhat6.6上安装ceph jewel安装包,而jewel(10.2.7)版本的源码依赖于gcc-4.8,所以必须在redhat6.6上先升级gcc到4.8版本。二....
  • zlarm
  • zlarm
  • 2017年04月20日 10:00
  • 958

Ubuntu14下gcc4.8和gcc4.7之间的切换

Ubuntu14自带GCC的版本是4.8,编译caffe的matlab接口时需要降级到4.7系统使用的gcc版本随着发布版本的不同而不同,在编译Android系统时不同的版本推荐用不同的gcc去编译,...
  • d5224
  • d5224
  • 2016年08月20日 15:07
  • 3924

CentOS6.5 64位GCC从4.4.2升级到4.8.5实录

1.资源准备 首先需要准备的资源有 gcc-4.8.5.tar.gz, 然后可能用到的有 gmp-4.3.2.tar.bz2,mpfr-3.1.4.tar.bz,mpc-1.0.3.tar.gz...
  • q229827701
  • q229827701
  • 2016年05月24日 19:49
  • 2440

gcc 4.8.3 for windows

  • 2014年06月18日 15:37
  • 53.73MB
  • 下载

Linux 编译安装 GCC 4.8

Linux 编译安装 GCC 4.8 Filed under: Article,Blablabla... — 标签4.8,centos,gcc,gcc 4.8,linux,安装,编译 — ...
  • pi9nc
  • pi9nc
  • 2013年05月17日 09:23
  • 2042

linux下安装GCC4.8.2(转载)

原网址:http://www.21ops.com/linux/14922.html C++11标准在2011年8月份获得一致通过,这是自1998年后C++语言第一次大修订,对C++语言进行了改...
  • a393308100
  • a393308100
  • 2014年03月26日 13:11
  • 1920

GCC安装 升级 版本4.8.2

最近要装llvm,结果发现要求gcc在4.7版本以上,于是去装gcc。最开始的时候使用gmp/mpfr/mpc这一套来安装,但是怎么装都没有对。这个以后再研究。后来发现根本没有这么麻烦,现在已经不需要...
  • rbb317
  • rbb317
  • 2015年01月05日 12:38
  • 1933

安装gcc 4.8.2 for cxx 11

from http://blog.csdn.net/stormbjm/article/details/9107831
  • aalbertini
  • aalbertini
  • 2014年09月12日 10:14
  • 3180

gcc 4.8.2 支持C++11

  • 2014年02月23日 20:43
  • 23.37MB
  • 下载
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:linux(Centos)下编译安装gcc4.8.2
举报原因:
原因补充:

(最多只允许输入30个字)