给你5个数a,b,c,d,k。x属于[a,b]y属于[c,d]。 问你有多少对(x,y)的公约数为k

题目大意:给你5个数a,b,c,d,k。x属于[a,b]y属于[c,d]。 问你有多少对(x,y)的公约数为k。 注意(x,y)和 (y,x)视为同一对。

x是[1,b],y是[1,d],求GCD(x,y)=k的对数(x,y无序)

对x,y都除以k,则求GCD(x,y)=1

此时枚举x,问题转化为[1,d]区间内与x互素的数字个数,这个问题是hdu 4135

有一个特殊的地方是x,y无序,对于这点只要保证x始终小于y就可以了


              注意特判k==0的情况

Problem Description
Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
 

Output
For each test case, print the number of choices. Use the format in the example.
 

Sample Input
  
  
2 1 3 1 5 1 1 11014 1 14409 9
 

Sample Output
  
  
Case 1: 9 Case 2: 736427
Hint
For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int s[100020],k;
void init(int m)
{
    k=0;
    for(int i=2; i*i<=m; i++)
    {
        if(m%i==0)
        {
            s[k++]=i;
            while(m%i==0)
                m/=i;
        }
    }
    if(m>1)
        s[k++]=m;
}
long long quc(int m)
{
    int t=0,p[100020],z;
    long long sum=0;
    p[t++]=-1;
    for(int i=0; i<k; i++)
    {
        z=t;
        for(int j=0; j<z; j++)
        {
            p[t++]=p[j]*s[i]*(-1);
        }
    }
    for(int i=1; i<t; i++)
    {
        sum+=m/p[i];
    }
    return sum;
}
int main()
{
    int n,a,b,c,d,m,g=0;
    long long sum;
    scanf("%d",&n);
    while(n--)
    {
        sum=0;
        scanf("%d %d %d %d %d",&a,&b,&c,&d,&m);
        g++;
        if(m==0||m>b||m>d)
            {printf("Case %d: 0\n",g);
            continue;
            }
        b=b/m;
        d=d/m;
        if(b>d)
            swap(b,d);
        for(int i=1; i<=b; i++)
        {
            init(i);
            sum+=d-quc(d)-i+1+quc(i-1);
            //printf("%d %d\n",quc(i-1),quc(d));
        }
        printf("Case %d: %I64d\n",g,sum);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值