poj 2325 Persistent Numbers 贪心+高精度除法

Description

The multiplicative persistence of a number is defined by Neil Sloane (Neil J.A. Sloane in The Persistence of a Number published in Journal of Recreational Mathematics 6, 1973, pp. 97-98., 1973) as the number of steps to reach a one-digit number when repeatedly multiplying the digits. Example: 
679 -> 378 -> 168 -> 48 -> 32 -> 6.

That is, the persistence of 679 is 6. The persistence of a single digit number is 0. At the time of this writing it is known that there are numbers with the persistence of 11. It is not known whether there are numbers with the persistence of 12 but it is known that if they exists then the smallest of them would have more than 3000 digits. 
The problem that you are to solve here is: what is the smallest number such that the first step of computing its persistence results in the given number?

Input

For each test case there is a single line of input containing a decimal number with up to 1000 digits. A line containing -1 follows the last test case.

Output

For each test case you are to output one line containing one integer number satisfying the condition stated above or a statement saying that there is no such number in the format shown below.

Sample Input

0
1
4
7
18
49
51
768
-1

Sample Output

10
11
14
17
29
77
There is no such number.
2688
 
     
 
     
 
     
ps:难点就在于大数除法,不过还好,大数除小数,用字符串存储。。。
贪心想法:从9除到2.逆序输出因子。。。。
代码:
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
int l;
char a[1100];
int k[1000020],tmp[1100];
bool div(int k)
{
    int j=0;
    int y=0;
    for(int i=0;i<l;i++)
    {
        int sum=a[i]+y*10;
        int x=sum/k;
         y=sum%k;
        if(x||j)
            tmp[j++]=x;
    }
    if(y)
        return false;
    for(int i=0;i<j;i++)
        a[i]=tmp[i];
    l=j;
    return true;
}
int main()
{
    while(~scanf("%s",&a))
    {if(a[0]=='-'&&a[1]=='1')
            break;
         l=strlen(a);
        int z=0;

         for(int i=0;i<l;i++)
            a[i]-='0';

        if(l==1)
            printf("1%d\n",a[0]);
        else
        {

            for(int i=9;i>=2;i--)
            {
               while(div(i))
               {//printf("####\n");
                   k[z++]=i;
               }
            }
            if(l!=1)
                printf("There is no such number.\n");
            else
            {for(int i=z-1;i>=0;i--)
                printf("%d",k[i]);
            printf("\n");
            }

        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值