HDU 1710 二叉树的遍历(已知前序和中序求后序)

Binary Tree Traversals

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6176    Accepted Submission(s): 2855


Problem Description
A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
 

Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
 

Output
For each test case print a single line specifying the corresponding postorder sequence.
 

Sample Input
  
  
9 1 2 4 7 3 5 8 9 6 4 7 2 1 8 5 9 3 6
 

Sample Output
  
  
7 4 2 8 9 5 6 3 1



http://acm.split.hdu.edu.cn/showproblem.php?pid=1710



#include <iostream>
#include <cstdio>
#include <cstring> 
#include <algorithm>
#include <stack>
using namespace std;
//给出二叉树的前序和中序, 求出其后序
// preorder , inorder , postorder 
/*
	结论:前序的第一个节点肯定是当前子树的根节点,
		 只要在中序找到这个节点,则其左边的都为左子树,右边的都为右子树 
*/

const int maxn=1000+5;
int n,pre[maxn],in[maxn];
stack<int> st;

//在压入栈的时候,根节点先进,然后压入右节点,然后压入左节点 
void creat(int start1,int end1,int start2,int end2) //分别是preorder的开始和末尾,inorder的开始和末尾
{
	int i,j;
	st.push(pre[start1]);
	for (i=start2;i<=end2;i++)
		if (in[i]==pre[start1]) break;//找到父节点在中序遍历的位置
	j=start1+(i-start2+1);//因为接下来遍历右子树,所以找出左右子树在preorder的分界点
	if (j<=end1&&i+1<=end2)
		creat(j,end1,i+1,end2);
	if (start1+1<=j-1&&start2<=i-1)
		creat(start1+1,j-1,start2,i-1);
}
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		for (int i=0;i<n;i++)
			scanf("%d",pre+i);
		for (int i=0;i<n;i++)
			scanf("%d",in+i);
		creat(0,n-1,0,n-1);
		while (!st.empty())
		{
			printf ("%d",st.top());
			st.pop();
			if (!st.empty()) putchar(' ');
		}
		puts("");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值