python3.6.1环境配置出现Requirement already up-to-date: pip in c:\python36\lib\site-packages决解方案

转载 2017年10月15日 13:16:12

前提:

windows下同时安装python2和python3,

应将python2和python3直接安装在 C盘下面,分别为python27和python36文件夹下。(避免Program Files的空格出现,后期会出错!)

为了方便同时使用,需将python3下的python.exe更名为python3.exe。(python2下的保持默认)

(当然win系统环境变量的path路径需要添加!python2的路径和pip的路径。python3的在安装的时候有钩选添加进去,如果没有沟选,也需要添加,python3.exe的和pip3.exe的。)

补充:win环境变量的Path路径添加方法(python)

     我的电脑-->属性-->高级-->环境变量-->系统变量-->找到变是为: PATH

      双击path,添加相应的路径(为避免插入出错,请添加到最前端)。

      例:

添加python36下的path:

1
C:\Python36;

注意,未尾没有斜杠!没有斜杠!没有斜杠!(我好像遇到一次加斜杠会失败的故障!不确定。)但末尾一定有分号,有分号!

添加python27下的path:

1
C:\Python27;


并且配置相应的pip 和pip3对应python2和python3(也更名!)(path略,同理)。


测试:

1、CMD中输入python,验证python.exe即2.7版本是否正确:

1
2
3
4
5
C:\Users\Administrator>python
Python 2.7.13 (v2.7.13:a06454b1afa1, Dec 17 201620:42:59) [MSC v.1500 32 bit (
Intel)] on win32
Type "help""copyright""credits" or "license" for more information.
>>>

返回信息正确!是python2版本。

1
exit()

退出!记得一定要退出呀!退出,退出,退出!重要的事说遍!


2、验证python3.exe

1
2
3
4
5
C:\Users\Administrator>python3
Python 3.6.1 (v3.6.1:69c0db5, Mar 21 201717:54:52) [MSC v.1900 32 bit (Intel)]
 on win32
Type "help""copyright""credits" or "license" for more information.
>>>

返回信息正确!是python3版本。

1
exit()

退出!记得一定要退出呀!退出,退出,退出!重要的事说遍!


3、验证pip.exe,查看它的版本号!输入pip -V

1
2
C:\Users\Administrator>pip -V
pip 9.0.1 from c:\python27\lib\site-packages (python 2.7)

正确!pip是来自python2版本!


4、验证pip3.exe:

1
2
C:\Users\Administrator>pip3 -V
Patal error in launcher:Unable to create process using '"'

返回信息,说出错了!


以往的做法,即python3.5.1的做法:升级重安装!

1
2
C:\Users\Administrator>python3 -m pip insatll pip
Requirement already up-to-date: pip in c:\python36\lib\site-packages

返回信息,说已经完成了!原因是python3.6.1的pip本来就是当前最新版本了,即无新更新安装。


怎么办?——解决方案:

1、删除C:\Python36\Lib\site-packages下的pip文件夹!

2、在官网重新下载最新的pip-9.0.1源文件:https://pypi.python.org/pypi/pip#downloads,

给个下载链接吧:

https://pypi.python.org/packages/11/b6/abcb525026a4be042b486df43905d6893fb04f05aac21c32c638e939e447/pip-9.0.1.tar.gz#md5=35f01da33009719497f01a4ba69d63c9

3、在python3下重新安装:在CMD中进入解压后的pip-9.0.1文件夹中,后执行命令:

比如我的解压放在C盘里,

1
2
3
C:\Users\Administrator>cd/
C:\>cd pip-9.0.1
C:\pip-9.0.1>python3 setup.py install

进入安装文件夹,执行命令,自动安装完毕!

4、记得,一定要记得,再次删除新生的pip.exe !!!(文件在C:\Python36\Scripts下面,保留原来的pip3.exe哦!)


再测试一下,是否pip3.exe成功:

1
2
C:\>pip3 -V
pip 9.0.1 from C:\Python36\lib\site-packages\pip-9.0.1-py3.6.egg (python 3.6)

返回信息,pip3是来自于python3版本中!


至此,双python版本环境配置安装完毕!


python欢迎您!鼓撑!!!


原文链接:qooqle

pip 升级的问题解决办法

from: http://blog.chenxiaosheng.com/posts/2016-05-19/pip_upgrade_pip_failure.html 今天在使用 python pi...
  • jasonzzj
  • jasonzzj
  • 2017年04月23日 16:43
  • 7257

Python学习记录六-ubuntu下升级pip报错

今天在Ubuntu下尝试安装Python的一些机器学习相关学习的库,使用pip命令提示 You are using pip version 8.1.1, however version 9.0.1...
  • chender_sysu
  • chender_sysu
  • 2017年04月06日 13:56
  • 897

pip安装和使用

pip用来管理和安装python包非常方便。怎么简单介绍下如何安装pip以及pip常用命令的使用 在线安装pip #curl -O https://raw.github.com/pypa/pip/ma...
  • angel22xu
  • angel22xu
  • 2014年02月20日 14:02
  • 6110

python升级引起的pip执行错误

centos5.x默认安装的python为2.4版本,但是部分软件需要2.5以上的python.所以我们需要升级Python,比如到2.7版本,步骤curl -O http://python.org/...
  • iefreer
  • iefreer
  • 2012年10月18日 17:47
  • 52326

windows python2 和python3

python3.6.1环境配置出现Requirement already up-to-date: pip in c:\python36\lib\site-packages决解方案 ...
  • u010510100
  • u010510100
  • 2017年09月09日 17:09
  • 380

Python安装环境搭建(python+pycharm+pid)

Python安装环境搭建(python+pycharm+pid): 准备软件: python3.4.3.msi     注:基本的程序编译器 pycharm-professional-4.5.3.ex...
  • typa01_kk
  • typa01_kk
  • 2015年10月19日 00:41
  • 9098

mac下安装numpy等python科学计算包

一种切实可行的方案; 终端中运行: Last login: Sat Jan  9 22:09:00 on console guoyiwendeMacBook-Air:~ skguoy...
  • skguoyiwen
  • skguoyiwen
  • 2016年01月09日 15:17
  • 7831

python pip的安装和使用

python pip的安装和使用
  • qqLiFu
  • qqLiFu
  • 2015年10月25日 18:32
  • 5066

pip install 问题

C:\Users\用户>pip install NumPy Collecting NumPy Exception: Traceback (most recent call last): F...
  • u013567842
  • u013567842
  • 2017年04月02日 23:58
  • 1932

windows环境下 pip 安装 seaborn 失败?

matploatlib 包很强大,但对于需要快速做一些基础图形的朋友来说 界面似乎有点简陋,基于matploatlib 开发seaborn 包 显得更好看一些,这点我很喜欢 这次安装并不是那么顺利,...
  • hanzhenqwe
  • hanzhenqwe
  • 2017年01月16日 13:40
  • 3762
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:python3.6.1环境配置出现Requirement already up-to-date: pip in c:\python36\lib\site-packages决解方案
举报原因:
原因补充:

(最多只允许输入30个字)