hdu 1054 Strategic Game【最小顶点覆盖】

Strategic Game

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6732    Accepted Submission(s): 3149


Problem Description
Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree: 

 

the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:
 

Sample Input
  
  
4 0:(1) 1 1:(2) 2 3 2:(0) 3:(0) 5 3:(3) 1 4 2 1:(1) 0 2:(0) 0:(0) 4:(0)
 

Sample Output
  
  
1 2

题目大意:给出这么些个城市和这么些个关系【城市和城市之间连接】【题干给出的是单向图】,每个护卫所在的城市如果有其他城市和他所在城市连接,那么护卫也能保护其他城市,问用最少的护卫放在城市中,能够保护到所有的城市。

思路:最小顶点覆盖【简单的说就是用最少的点,覆盖所有的边、】

无向图的最大二分匹配数/2==最小顶点覆盖

所以这个图我们要建成无向图,然后找到最大二分匹配数。最后/2 

优化方法:vetor建立邻接表~~

AC代码:

#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
vector<int >mp[1505];
int vis[1505];
int match[1505];
int  find(int x)
{
    for(int i=0;i<mp[x].size();i++)
    {
        int v=mp[x][i];
        if(vis[v]==0)
        {
            vis[v]=1;
            if(match[v]==-1||find(match[v]))
            {
                match[v]=x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
        {
            mp[i].clear();
        }
        for(int i=0;i<n;i++)
        {
            int u,k;
            scanf("%d:(%d)",&u,&k);
            for(int j=0;j<k;j++)
            {
                int v;
                scanf("%d",&v);
                mp[u].push_back(v);
                mp[v].push_back(u);
            }
        }
        int sum=0;
        memset(match,-1,sizeof(match));
        for(int i=0;i<n;i++)
        {
            memset(vis,0,sizeof(vis));
            if(find(i))sum++;
        }
        printf("%d\n",sum/2);
    }
}











  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值