POJ 2485 Highways【最小生成树】

Highways
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 27493 Accepted: 12554

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed. 
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

Sample Output

1
3
0 990 692
990 0 179
692 179 0

692

Hint

Huge input,scanf is recommended.

Source

POJ Contest,Author:Mathematica@ZSU

题目大意:要想连接所有城市并建造高速公路,使得花费最小的情况下,输出消耗最大的那条高速公路需要的花费。


思路:克鲁斯卡尔贪心求最大边,代码实现很简单。


AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct path
{
    int x,y,w;
}a[500*500+50];
int f[5000];
int cmp(path a,path b)
{
    return a.w<b.w;
}
int find(int a)
{
    int r=a;
    while(f[r]!=r)
    r=f[r];
    int i=a;
    int j;
    while(i!=r)
    {
        j=f[i];
        f[i]=r;
        i=j;
    }
    return r;
}
void merge(int a,int b)
{
    int A,B;
    A=find(a);
    B=find(b);
    if(A!=B)
    f[B]=A;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        int cont=0;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            f[i]=i;
            for(int j=0;j<n;j++)
            {
                int k;
                scanf("%d",&k);
                a[cont].x=i;
                a[cont].y=j;
                a[cont++].w=k;
            }
        }
        int output;
        int tmp=0;
        sort(a,a+cont,cmp);
        for(int i=0;i<cont;i++)
        {
            if(find(a[i].x)!=find(a[i].y))
            {
                merge(a[i].x,a[i].y);
                tmp++;
                if(tmp==n-1)//如果是最后一条入边,那么这条边一定是权值最大边
                {
                    output=a[i].w;
                }
            }
        }
        printf("%d\n",output);
    }
}










评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值