POJ 3159 Candies【差分约束+SPFA】

Candies

Time Limit: 1500MS

 

Memory Limit: 131072K

Total Submissions: 28026

 

Accepted: 7731

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 throughN. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers AB and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2

1 2 5

2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.

Source

POJ Monthly--2006.12.31, Sempr

 

题目大意:给n个人分糖果,给出m个约数条件,每组包含三个数a,b,c,表示b的糖果数比a的糖果数不能多c个,即b-a<=c

问n比1最多能够多多少糖果。


题目分析:

明显的差分约束系统问题,能够将问题转化为最短路问题。以下给出转化过程及详解:

假设有这样的三个条件:


我们不妨把1,2,3三个人都看成节点,然后设k1,k2,k3为三条有向边的权值,那么1-2这条边能够取值为【0,k1】因为我们要求最大值,那么我们必然要取1-2这条边的权值为k1,2-3这条边的权值为k2,1-3这条边的权值为k3。

将约束条件转化为有向图:


我们再根据约束条件1和约束条件2相加,得到约束条件:1-3<=k1+k2,我们还有1-3<=k3两者同时成立,那么k1+k2和k3这两个数,最小的就是1比3多的糖果数。

我们再根据有向图的最短路松弛过程有:k1+k2与k3相比较,最小的就是3到1的有向图最短路径,那么不难理解,由差分约束问题很容易就转化到了最短路问题上来。


再因为数据比较大,我们采用SPFA+stack+读入外挂(fast IO)来优化这个问题,最后剩下的就是代码实现问题:


#include<stdio.h>
#include<string.h>
#include<queue>
#include<stack>
using namespace std;
#define INF 0x3f3f3f3f
int head[30010];
struct EdgeNode
{
    int to;
    int w;
    int next;
}e[150010];
int vis[30010];
int dis[30010];
int n,m;
int cont;
void add(int from,int to,int w)
{
    e[cont].to=to;
    e[cont].w=w;
    e[cont].next=head[from];
    head[from]=cont++;
}
int Scan()
{
    int res = 0, ch, flag = 0;

    if((ch = getchar()) == '-')             //判断正负
        flag = 1;

    else if(ch >= '0' && ch <= '9')           //得到完整的数
        res = ch - '0';
    while((ch = getchar()) >= '0' && ch <= '9' )
        res = res * 10 + ch - '0';

    return flag ? -res : res;
}
void SPFA(int start)
{
    memset(vis,0,sizeof(vis));
    for(int i=0;i<=n;i++)dis[i]=INF;
    stack<int >s;
    s.push(start);
    vis[start]=1;
    dis[start]=0;
    while(!s.empty())
    {
        int u=s.top();
        //printf("u:%d\n",u);
        s.pop();vis[u]=0;
        for(int j=head[u];j!=-1;j=e[j].next)
        {
            int v=e[j].to;
            int w=e[j].w;
            //printf("%d %d\n",v,w);
            if(dis[v]>dis[u]+w)
            {
                dis[v]=dis[u]+w;
                if(vis[v]==0)
                {
                    s.push(v);
                    vis[v]=1;
                }
            }
        }
    }
    printf("%d\n",dis[n]);
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        cont=0;
        memset(head,-1,sizeof(head));
        for(int i=0;i<m;i++)
        {
            int x,y,w;
            x=Scan();
            y=Scan();
            w=Scan();
            add(x,y,w);
        }
        SPFA(1);
    }
}









CCF大数据与计算智能大赛-面向电信行业存量用户的智能套餐个性化匹配模型联通赛-复赛第二名-【多分类,embedding】.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值