Poj 3268 Silver Cow Party【SPFA】

Silver Cow Party

Time Limit: 2000MS

 

Memory Limit: 65536K

Total Submissions: 17517

 

Accepted: 8021

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Inputdf

Line 1: Three space-separated integers, respectively: NM, and X 
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: AiBi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2

1 2 4

1 3 2

1 4 7

2 1 1

2 3 5

3 1 2

3 4 4

4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

Source

USACO 2007 February Silver

 

题目大意:有n个点,m条有向边,X作为宴会开始的地方,一开始,所有除X以外的点都要到X去,然后当宴会结束的时候,都要各回各家,问最慢到家的耗时为多少。


思路:

1、反向建边,求所有除X点以外的点到X去的最短路,这时候也就是以X为节点的单源最短路。


2、正向建边,求X到其他各个点的最短路,这时候也是求以X为节点的单源最短路。


3、output=max(output,dis【i】+dis2【i】)【1<=i<=n】;


AC代码:


#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int head[100000];
struct EdgeNode
{
    int to;
    int w;
    int next;
}e[1000000];
int w[1000000];
int x[1000000];
int y[1000000];
int dis2[100000];
int dis[100000];
int vis[100000];
int n,m,cont,pos;
void add(int from,int to,int w)
{
    e[cont].to=to;
    e[cont].w=w;
    e[cont].next=head[from];
    head[from]=cont++;
}
void SPFA(int ss)
{
    queue<int >s;
    memset(vis,0,sizeof(vis));
    vis[ss]=1;
    s.push(ss);
    for(int i=1;i<=n;i++)dis[i]=0x3f3f3f3f;
    dis[ss]=0;
    while(!s.empty())
    {
        int u=s.front();
        s.pop();
        vis[u]=0;
        for(int j=head[u];j!=-1;j=e[j].next)
        {
            int v=e[j].to;
            int w=e[j].w;
            if(dis[v]>dis[u]+w)
            {
                dis[v]=dis[u]+w;
                if(vis[v]==0)
                {
                    s.push(v);
                    vis[v]=1;
                }
            }
        }
    }
}
void SPFA2(int ss)
{
    queue<int >s;
    memset(vis,0,sizeof(vis));
    vis[ss]=1;
    s.push(ss);
    for(int i=1;i<=n;i++)dis2[i]=0x3f3f3f3f;
    dis2[ss]=0;
    while(!s.empty())
    {
        int u=s.front();
        s.pop();
        vis[u]=0;
        for(int j=head[u];j!=-1;j=e[j].next)
        {
            int v=e[j].to;
            int w=e[j].w;
            if(dis2[v]>dis2[u]+w)
            {
                dis2[v]=dis2[u]+w;
                if(vis[v]==0)
                {
                    s.push(v);
                    vis[v]=1;
                }
            }
        }
    }
}
int main()
{
    while(~scanf("%d%d%d",&n,&m,&pos))
    {
        cont=0;
        memset(head,-1,sizeof(head));
        for(int i=0;i<m;i++)
        {
            int xx,yy,ww;
            scanf("%d%d%d",&xx,&yy,&ww);
            add(xx,yy,ww);
            x[i]=xx;
            y[i]=yy;
            w[i]=ww;
        }
        SPFA(pos);
        cont=0;
        memset(head,-1,sizeof(head));
        for(int i=0;i<m;i++)
        {
            add(y[i],x[i],w[i]);
        }
        SPFA2(pos);
        int output=0;
        for(int i=1;i<=n;i++)
        {
            if(i==pos)continue;
            output=max(output,dis[i]+dis2[i]);
        }
        printf("%d\n",output);
    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值