Poj 3186 Treats for the Cows【区间dp】

Treats for the Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5427 Accepted: 2825

Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time. 

The treats are interesting for many reasons:
  • The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally? 

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5
1
3
1
5
2

Sample Output

43

Hint

Explanation of the sample: 

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2). 

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.

Source


题目大意:

给你N个物品,我们每次只能从两边拿,对于第i个拿出来的物品,那么其价值就增加i*这个物品的价值。

问拿取的最大价值是多少。


思路(这个区间dp好水啊):


1、设定dp【i】【j】表示从i到j的拿取的最大的价值是多少。


2、我们考虑逆向考虑,那么我们对于区间【i,j】,可以是区间【i,j-1】再添加一个a【j】得来,也可以是区间【i+1,j】添加一个a【i】得来。

那么对应有:

①dp【i】【j】=max(dp【i】【j】,dp【i】【j-1】+(i+n-j)*a【j】);

②dp【i】【j】=max(dp【i】【j】,dp【i+1】【j】+(i+n-j)*a【i】);


3、ans=dp【1】【n】;


Ac代码:


#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
#define ll __int64
ll dp[2005][2005];
ll a[2005];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%I64d",&a[i]);
        }
        memset(dp,0,sizeof(dp));
        for(int len=0;len<=n;len++)
        {
            for(int i=1;i+len<=n;i++)
            {                
                int j=i+len;
                if(len==0)
                {
                    dp[i][j]=a[i]*n;
                }
                else
                {
                    dp[i][j]=max(dp[i][j],dp[i][j-1]+(i+n-j)*a[j]);
                    dp[i][j]=max(dp[i][j],dp[i+1][j]+(i+n-j)*a[i]);
                }
            }
        }
        printf("%I64d\n",dp[1][n]);
    }
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值