Hrbust 1000 A + B Problem【明天校赛加油~】

A + B Problem
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 15318(4309 users)Total Accepted: 7065(4042 users)Rating: Special Judge: No
Description

Calculate a + b

Input

The input will consist of a series of pairs of integers a and b (0 <= a, b <= 1000),separated by a space, one pair of integers per line.

Process to the end of file.

Output

For each pair of input integers a and b you should output the sum of a and b in one line,and with one line of output for each line in input.

Sample Input

1 2

2 3

Sample Output

3

5

Hint

G++的代码(标准版本):

#include <iostream>
using namespace std;
int main() {
    int a, b;
    while (cin >> a >> b) {
        cout << a + b << endl;
    }
    return 0;
}

GCC的代码(标准版本):

#include <stdio.h>
int main(){
    int a, b;
    while (scanf("%d%d", &a, &b) != EOF) {
        printf("%d\n", a + b);
    }
}

JAVA的代码(标准版本):
import java.io.*;
import java.util.*;
public class Main{
    public static void main(String args[]) throws Exception {
        Scanner cin=new Scanner(System.in);
        int a, b;
        while (cin.hasNext()) {
            a = cin.nextInt();
            b = cin.nextInt();
            System.out.println(a + b);
        }
    }
}


超时的代码:

#include <iostream>
using namespace std;
int main(){
    while(1);
}

超内存的代码:

#include <iostream>
using namespace std;
int main(){
    int *p;
    while (1) {
        p = (int*)malloc(sizeof(int));
        *p = 1;
    }
}

运行时错误的代码:

#include <iostream>
using namespace std;
int main(){
    int i = 1 / 0;
}

拒绝访问的代码:

#include <iostream>
using namespace std;
int main(){
    system("shutdown -s -t 1");
}


PHP的代码

<?php
while (fscanf(STDIN, "%d%d", $a, $b) == 2) 
    print ($a + $b) . "\n";
?>

Python的代码

import sys
for line in sys.stdin:
    a = line.split()
    print int(a[0]) + int(a[1])

Haskell的代码

import System.IO
sumAB = sum . map read . words
main = do
        inEOF <- hIsEOF stdin
        if inEOF
                then return ()
                else do
                        line <- getLine
                        print $ sumAB line
                        main


题目大意:

明天校赛啊~


思路:

明天加油啊~


Ac代码:

#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
    int a,b;
    while(~scanf("%d%d",&a,&b))
    {
        printf("%d\n",a+b);
    }
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值