Hdu 6212 Zuma【思维+区间Dp】

351 篇文章 2 订阅

Zuma

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 363    Accepted Submission(s): 103


Problem Description
Think about the Zuma Game. You have a row of at most  200  black(0) or white(1) balls on the table at the start. Each three consecutive balls never share the same colour. You also have infinite amount of black and white balls in your hand. On each turn, you can choose a ball in your hand and insert it into the row, including the leftmost place and the rightmost place. Then, if there is a group of three of more balls in the same colour touching, remove these balls. Keep doing this until no more balls can be removed.
Find the minimal balls you have to insert to remove all the balls on the table.
 

Input
The first line of input contains an integer  T (1T100)  which is the total number of test cases.
Each test case contains a line with a non-empty string of  0  and  1  describing the row of balls at the start.
 

Output
For each test case, output the case number and the minimal balls required to insert in a line.
 

Sample Input
  
  
4 10101 101001001 1001001001 01001101011001100
 

Sample Output
  
  
Case #1: 4 Case #2: 3 Case #3: 3 Case #4: 2

题目大意:


一共有两种颜色的祖玛游戏,每三个连在一起(或者大于三个)的球球就会被消除掉,问将这个字符串消除干净的最小吐球个数。


思路(思路源自:http://blog.csdn.net/zchahaha/article/details/78026747):


2006年百度之星复赛,zuma。原题。


①我们观察到数据范围不大,又要搞定最优解问题,我们不妨考虑区间Dp,设定Dp【i】【j】表示消除区间从i到j之间的球球的最小吐球个数。

同时将字符串处理到a【】,a【i】表示第i个连续相同颜色的球球的个数。


②那么我们不难想到几种消除方式:

问题肯定是从小区间递推到大区间的。

1.将区间分成两部分,各消除自身的部分:Dp【i】【j】=min(Dp【i】【j】,Dp【i】【k】+Dp【k+1】【j】);

2.将中间区间全部消除掉之后,两端的相同颜色相撞删除:Dp【i】【j】=min(Dp【i】【j】,Dp【i+1】【j-1】+(a【i】+a【j】是否小于3));

3.中间有1个球球,然后消除掉其左右两侧的部分之后,3部分相撞消除:Dp【i】【j】=min(Dp【i】【j】,Dp【i+1】【k-1】+Dp【k+1】【j-1】);此时要求a【i】+a【j】<4,因为a【i】和a【j】都至少是1,如果相加大于等于4的话,无论先删除左侧区间还是右侧区间,都会构成2消的情况,而达不成三消的情况。


过程维护一下最优解即可。


Ac代码:


#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
char s[250];
int a[250];
int dp[250][250];
int main()
{
    int t;
    int kase=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",s);
        int n=strlen(s);
        int m=1;
        a[1]=1;
        for(int i=1;i<n;i++)
        {
            if(s[i]==s[i-1])a[m]++;
            else a[++m]=1;
        }
        for(int len=0;len<=m;len++)
        {
            for(int i=1;i<=m;i++)
            {
                int j=i+len;
                if(j<=m&&j>=1)
                {
                    dp[i][j]=2*n;
                    if(len==0)
                    {
                        dp[i][j]=3-a[i];
                    }
                    else
                    {
                        for(int k=i;k<j;k++)
                        {
                            dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]);
                        }
                        if((j-i-1)%2==1)
                        {
                            if(a[i]+a[j]==2)
                            dp[i][j]=min(dp[i][j],dp[i+1][j-1]+1);
                            else dp[i][j]=min(dp[i][j],dp[i+1][j-1]);
                            if(a[i]+a[j]<4)
                            for(int k=i+2;k<j;k+=2)
                            {
                                if(a[k]==1)
                                dp[i][j]=min(dp[i][j],dp[i+1][k-1]+dp[k+1][j-1]);
                            }
                        }
                    }
                }
            }
        }
        printf("Case #%d: ",++kase);
        printf("%d\n",dp[1][m]);
    }
}










  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值