Rotating Sentences

Rotating Sentences

 Rotating Sentences 

In ``Rotating Sentences,'' you are asked to rotate a series of input sentences 90 degrees clockwise. So instead of displaying the input sentences from left to right and top to bottom, your program will display them from top to bottom and right to left.


Input and Output

As input to your program, you will be given a maximum of 100 sentences, each not exceeding 100 characters long. Legal characters include: newline, space, any punctuation characters, digits, and lower case or upper case English letters. (NOTE: Tabs are not legal characters.)


The output of the program should have the last sentence printed out vertically in the leftmost column; the first sentence of the input would subsequently end up at the rightmost column.


Sample Input


Rene Decartes once said,
"I think, therefore I am."


Sample Output


"R
Ie
 n
te
h 
iD
ne
kc
,a
 r
tt
he
es
r
eo
fn
oc
re
e
 s
Ia
 i
ad
m,
.
"

这个题目不需要解释

但是怎么输入一开始成为的我的最大的问题,怎么输入呢,本来先用while(gets(a))但是一想,如果把处理流程放到里面,敲回车,应该就会出结果,不可能实现最后一组在前面的情况,所以说这件事让我思考半天,后来,我果断的吧处理流程放到了输入循环的循环外面,但是有一个问题出现了,怎么结束循环呢,它会一直输入下去,其实这件事不用你担心Ctrl+Z就可以结束,后台运行的时候都是这样设计的。

常见错误:

因为每个字符串的长度不一样,怎么才能控制输出,这就一个巧妙之处,题目上说,空格是合法字符,所以,用空格代替(条件判断),一开始不要忘记初始化,这样才能做出条件判断。你可以发现,如果,你把if去掉,直接输出(printf("%c",a[k][j]);)

和加if进行条件判断的结果一样,但是,如果你去交你就wa了,为什么呢,因为%c输出的,‘/0’是空字符,虽然看着和空格一样不输出,但是,实质还是不一样的,空字符不合法!(我就在里错了几遍)。

#include<stdio.h>
#include<string.h>
int main()
{
    char a[110][110]={0};
    int i,j,k,maxlen=0;
    i=0;
    while(gets(a[i])!=NULL)
    {
        if(strlen(a[i])>maxlen)
                maxlen=strlen(a[i]);
        i++;
    }
    for(j=0;j<maxlen;j++)
        for(k=i-1;k>=0;k--)
        {
            if(a[k][j]==0)
                printf(" ");
            else
                printf("%c",a[k][j]);
            if((!k))
                printf("\n");
        }
        return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值