Marvelous Mazes

Your mission, if you decide to accept it, is to create a maze drawing program. A maze will consist of the alphabetic characters A-Z, * (asterisk), and spaces.


Input and Output

Your program will get the information for the mazes from the input file. This file will contain lines of characters which your program must interpret to draw a maze. Each row of the maze will be described by a series of numbers and characters, where the numbers before a character tell how many times that character will be used. If there are multiple digits in a number before a character, then the number of times to repeat the character is the sum of the digits before that character.

The lowercase letter "b" will be used in the input file to represent spaces in the maze. The descriptions for different rows in the maze will be separated by an exclamation point (!) or by an end of line.


Descriptions for different mazes will be separated by a blank line in both input and output. The input file will be terminated by an end of file.

There is no limit to the number of rows in a maze or the number of mazes in a file, though no row will contain more than 132 characters.

Happy mazing!


Sample Input


1T1b5T!1T2b1T1b2T!1T1b1T2b2T!1T3b1T1b1T!3T3b1T!1T3b1T1b1T!5T1*1T
 
11X21b1X
4X1b1X


Sample Output


T TTTTT
T  T TT
T T  TT
T   T T
TTT   T
T   T T
TTTTT*T
 
XX   X
XXXX X

这道题是不需要翻译的,因为你看图差不多就了解是什么意思了,大概意思是说,让你按照你输入的文字去编个迷宫,迷宫由(A—Z)、*、b、!组成的,其中(A—Z)代表wall,*代表出口,b代表空间,!代表换行,前面的的数字代表有多少个这样的后面内涵字符,注意,例如,21代表3,而不是二十一!

是否对输入纠结呢?(因为看见示例里有一个空行)不要管那个,因为,你会发现,你输入一个回车字符(就是敲回车),它就返回一个空行,是这个意思,不是说,要在输入后输出空行!

#include<stdio.h>
int main()
{
	int i,j,k,n,m;
	char a[133];
	while(gets(a))
	{
		i=0;
		n=0;
		while(a[i]!='\0')
		{
			if('0'<=a[i]&&a[i]<='9')
			{
				n+=(a[i]-'0');
				if(!('0'<=a[i+1]&&a[i+1]<='9'))
				{
					m=n;
					n=0;
				}
			}
			if('A'<=a[i]&&a[i]<='Z')
			{
				for(j=1;j<=m;j++)
				{
					printf("%c",a[i]);
				}
			}
			if(a[i]=='b')
			{
				for(j=1;j<=m;j++)
				{
					printf(" ");
				}
			}
			if(a[i]=='!')
				printf("\n");
			if(a[i]=='*')
				for(j=1;j<=m;j++)
					printf("*");
			i++;
		}
		printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值