POJ 1006-Biorhythms-生理周期峰值(中国剩余问题)

Biorhythms
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 129233 Accepted: 41094

Description

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. 
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak. 

Input

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

Output

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form: 

Case 1: the next triple peak occurs in 1234 days. 

Use the plural form ``days'' even if the answer is 1.

Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

Source


题目意思:

解同余方程组:
X≡p(mod 23)
X≡e(mod 28)
X≡i(mod 33)

解题思路:

模板题,中国剩余问题

#include <iostream>≡≡
#include <cstdio>
#include <cstring>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <algorithm>
#define INF 0xfffffff
int a[10],m[10],D,M;
using namespace std;

void extgcd(int a,int b,int &d,int &x,int &y)
{
    if (b==0)
    {
        x=1;
        y=0;
        return ;
    }
    extgcd(b,a%b,d,x,y);
    int t = x;
    x = y;
    y = t - a/b * y;
}

int china(int r)
{
    M=1;
    int i,Mi,x0,y0,ans=0,d;
    for(i=0; i<r; ++i)
        M*=m[i];
    for(i=0; i<r; ++i)
    {
        Mi=M/m[i];
        extgcd(Mi,m[i],d,x0,y0);
        ans=(ans+Mi*x0*a[i])%M;
    }
    if(ans<0) ans+=M;
    return ans;
}

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    int n=3,ca=0;
    m[0]=23,m[1]=28,m[2]=33;
    while(cin>>a[0]&&a[0]!=-1)
    {
        for(int i=1; i<n; ++i)
            cin>>a[i];
        cin>>D;
        int ans=china(n);
        while(ans<=D)
            ans+=M;
        cout<<"Case "<<++ca<<": the next triple peak occurs in "<<ans-D<<" days."<<endl;
    }
    return 0;
}
/**
0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1
**/

#include <iostream>
using namespace std;
int main()
{
    int p,e,i,d;
    int x;
    int index = 1;
    while((cin>>p>>e>>i>>d)&&(p!=-1)&&(e!=-1)&&(i!=-1)&&(d!=-1))
    {
        p%=23;
        e%=28;
        i%=33;
        x=i;
        while(!((x-p)%23==0 && (x-e)%28==0))
        {
            x += 33;
        }
        x -= d;
        if(x<=0) x += 21252;
        cout<<"Case "<<index<<": the next triple peak occurs in "<<x<<" days."<<endl;
        index++;
    }
    return 0;
}


知识点总结:

中国剩余定理

p+23a=x;

e+28b=x;

i+33c=x;

其实就是求能被23除余p,能被28除余e,能被33除余i的最小的数。

这样我们可以用中国剩余定理(自行百度):

假设:t1能被28、33整除,能被23除余1;

            t2能被23、33整除,能被28除余1;

            t3能被23、28整除,能被33除余1;

那么:t1*p能被28、33整除,能被23除余p;

            t2*e能被23、33整除,能被28除余e;

            t3*i能被23、28整除,能被33除余i;

所以,t1*p+t2*e+t3*i就是一个能被23除余p,能被28除余e,能被33除余i的数,但是它不一定是最小的,需要减掉n个23、28、33的最小公倍数,这样就能得到x。但是我们要计算的是给定日期d到x的天数,就需要x - d > 0。

学习心得:

第一种是逐步满足法,方法麻烦一点,但适合所有这类题目。
第二种是最小共倍法,方法简单,但只适合特殊类型的题目。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值