POJ-2013 Symmetric Order-对称排列人名

Symmetric Order
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 12811 Accepted: 7772

Description

In your job at Albatross Circus Management (yes, it's run by a bunch of clowns), you have just finished writing a program whose output is a list of names in nondescending order by length (so that each name is at least as long as the one preceding it). However, your boss does not like the way the output looks, and instead wants the output to appear more symmetric, with the shorter strings at the top and bottom and the longer strings in the middle. His rule is that each pair of names belongs on opposite ends of the list, and the first name in the pair is always in the top part of the list. In the first example set below, Bo and Pat are the first pair, Jean and Kevin the second pair, etc. 

Input

The input consists of one or more sets of strings, followed by a final line containing only the value 0. Each set starts with a line containing an integer, n, which is the number of strings in the set, followed by n strings, one per line, sorted in nondescending order by length. None of the strings contain spaces. There is at least one and no more than 15 strings per set. Each string is at most 25 characters long.

Output

For each input set print "SET n" on a line, where n starts at 1, followed by the output set as shown in the sample output.

Sample Input

7
Bo
Pat
Jean
Kevin
Claude
William
Marybeth
6
Jim
Ben
Zoe
Joey
Frederick
Annabelle
5
John
Bill
Fran
Stan
Cece
0

Sample Output

SET 1
Bo
Jean
Claude
Marybeth
William
Kevin
Pat
SET 2
Jim
Zoe
Frederick
Annabelle
Joey
Ben
SET 3
John
Fran
Cece
Stan
Bill

Source


直接找规律。。
#include <iostream>
using namespace std;

int main()
{
    int t,i,count=1;;
    while(cin>>t&&t!=0)
    {
        string s[t];
        for(i=0; i<t; ++i)
            cin>>s[i];
        cout<<"SET "<<count<<endl;
        for(i=0; i<t; i+=2)
            cout<<s[i]<<endl;
        i-=2;
        if(t%2==0)
        {
            for(i++; i>0; i-=2)
                cout<<s[i]<<endl;
        }
        else
        {
            for(i--; i>0; i-=2)
                cout<<s[i]<<endl;
        }
        ++count;
    }
    return 0;
}



用递归,放在栈里,先进后出。。
#include <iostream>
using namespace std;

void print(int n)
{
    string s;
    cin>>s;
    cout<<s<<endl;
    if(--n)
    {
        cin>>s;
        if(--n)
            print(n);
        cout<<s<<endl;
    }
}

int main()
{
    int n,loop=0;
    cin>>n;
    while(n)
    {
        cout<<"SET "<<++loop<<endl;
        print(n);
        cin>>n;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值