POJ 1129-Channel Allocation(顶点着色)

Channel Allocation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14559 Accepted: 7406

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. 

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. 

Following the number of repeaters is a list of adjacency relationships. Each line has the form: 

A:BCDH 

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form 

A: 

The repeaters are listed in alphabetical order. 

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 

Source


题目意思:

N个中继器,随后的N行中,A: 后面是与A相邻的中继器编号。

对于一个给定的中继器网络,所使用频道数应当尽可能地少,计算使用最少频道的数目。

解题思路:

顺序着色法求解。

无向图,染色,判断一共用了多少种颜色。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <algorithm>
using namespace std;
#define INF 0xfffffff
#define maxn 100010
char s[26];//读入
int edge[26][26];//邻接矩阵
int n;//中继器数目
int ans,c[26];//顶点着色数、各个顶点的颜色
int b[26];//1表示该种颜色已经被使用
void greedy()
{
    int i,j;
    for(i=0; i<n; ++i)//给第i个顶点着色
    {
        memset(b,0,sizeof(b));
        for(j=0; j<n; ++j)//检查顶点i的每个邻接顶点
            if(edge[i][j]&&c[j]!=-1)//邻接顶点j已经着色且颜色为c[k]
                b[c[j]]=1;
        for(j=0; j<=i; ++j)//j是顶点i的所有邻接顶点中未使用的且编号最小的颜色
            if(!b[j]) break;
        c[i]=j;//顶点i着第j种颜色
    }
    for(i=0; i<n; ++i)
        if(ans<c[i]) ans=c[i];
    ++ans;
}
int main()
{
    int i,j;
    while(cin>>n,n)
    {
        memset(edge,0,sizeof(edge));
        for(i=0; i<n; ++i) c[i]=-1;
        ans=0;
        for(i=0; i<n; ++i)
        {
            cin>>s;
            int m=strlen(s)-2;
            for(j=0; j<m; ++j)//根据相邻关系建图
            {
                edge[i][s[j+2]-'A']=1;
                edge[s[j+2]-'A'][i]=1;
            }
        }
        greedy();
        if(ans!=1) cout<<ans<<" channels needed."<<endl;//注意ans=1要特判
        else cout<<ans<<" channel needed."<<endl;
    }
}
/**
2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0
**/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值