PAT甲级-1001. A+B Format (20)逗号分隔

1001. A+B Format (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991

计算A+B的值,结果的每3个数位用一个逗号分隔开。

#include<bits/stdc++.h>
using namespace std;
#define MAXN 1000010
#define INF 0xfffffff
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("F:/cb/read.txt","r",stdin);
    //freopen("F:/cb/out.txt","w",stdout);
#endif
    ios::sync_with_stdio(false);
    cin.tie(0);
    int a,b,ans,i,j,cnt=0;
    bool flag=true;//正负标志
    cin>>a>>b;
    ans=a+b;
    //cout<<"ans="<<ans<<endl;
    if(ans<0) flag=false,ans=abs(ans);
    char s[MAXN],c[MAXN];
    while(ans>0)//int转字符串
    {
        s[cnt++]=char(ans%10+'0');
        ans/=10;
    }
    if(ans==0) c[0]='0';
    cnt=0;
    for(i=strlen(s)-1; i>=0; --i)
        c[cnt++]=s[i];
    //cout<<"c="<<c<<endl;
    int len=strlen(c);
    int temp=len/3;
    if(len%3==0) --temp;//逗号个数
    //cout<<"len="<<len<<endl;
    cnt=0;
    if(!flag) cout<<"-";
    for(i=0; i<len-3*temp; ++i)
        cout<<c[i];
    if(temp>0)
    {
        cout<<",";
        for(j=i; j<len; ++j)
        {
            if(cnt==3)
            {
                cnt=0;
                cout<<",";
            }
            cout<<c[j];
            ++cnt;
        }
    }
    cout<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值